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modules of the guide. Moreover, the green circles direct the 
reader at the most important aspects in an attempt to grasp 
quickly the essentials and hereby attempts to minimise the 
time needed to get going with RCtool. Enjoy!

Last modification of this guide was made as of 9.Mar.2021  

Importing from another RCtool data base 47
Importing data via Pro mode 50

How to correct for a bad import? 55............................................................................

Check internal consistency of your RCtool data base 58
Resolving conflicts from redundancies (duplicates) 59
Analysing Comments 62
Finding comments via clipboard 64
Using shortcuts 65
Archiving RCtool data 66

RCtool guide /2 67



 
On RCtool
RCtool supports the management of review comments that accrue during the 
preparation of IPCC (Intergovernmental Panel on Climate Change) reports. It is highly 
specialised and designed for internal use by IPCC only. It was originally designed to 
support only the IPCC Review Editors (REs) in their work. This lead to the name of the 
tool, 'RCtool'. However, in its current version 'RCtool' is designed such that it is useful 
for anyone handling IPCC drafts and review comments, notably Co-chairs and other Bu-
reau members, REs (Review Editors), authors such as CLAs (Coordinating Lead Au-
thors) or LAs (Lead Authors) and chapter scientists, as well as for TSUs (Technical Sup-
port Units). To this end RCtool offers and knows three roles: RE, Author, and Other.

RCtool is a freely available software that can be downloaded from its home page:    
 

 www.sysecol3.ethz.ch/RCtool/

Objectives of RCtool
 RCtool helps

• to read Review Comments and IPCC drafts  (all roles)
• to enter Author Responses to Review Comments  (authors)
• to annotate Review Comments and Author Responses  (REs)
• to analyze Review Comments and produce statistics  (all roles)

 One particular strength of RCtool is to help the user to immediately jump to the 
passage in the draft, which is referenced by a Review Comment.  RCtool can do this 2

not only for the draft to which the comment pertains, but also to a second draft, the so-
called comparison draft. Say a comment pertains to a figure, then RCtool allows you to 
jump not only to the original figure commented on, but also to the new figure in the next 
draft the authors have prepared in responding to the comment. A comparison can also 
be made backwards, i.e. you can jump directly to the old figure in the previous draft. 
Such comparisons can be done freely among any draft of an IPCC report, i.e. the ZOD , 3

FOD , SOD , and FGD .4 5 6

 Note, this feature is currently not available on iOS devices2

 ZOD stands for Zero Order Draft, sometimes also called Internal Draft3

 FOD stands for First Order Draft, also called Document for Expert Review4

 SOD stands for Second Order Draft, also called Document for Government and Expert Review5

 FGD stands for Final Government Draft6
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 Another strength of RCtool is that it provides means of smooth collaboration among 
team members, may this be a team of REs or a team of authors as the drafting ad-
vances over the years. In general RCtool provides a wealth of features and functions. It 
is highly flexible and can be customized to specific needs. All these features are too 
numerous to describe fully. Instead this guide describes typical uses and the most ba-
sics of the user interface to get quickly familiar with RCtool. Pick and choose whatever 
you are interested in.

Finally note that RCtool supports every stage of a draft preparation up to the final re-
lease. Hereby following overview may be helpful in understanding how an IPCC report is 
prepared and the workings of RCtool:

RCtool supports its users in all steps at all stages. It has been designed to accumulate 
and hold all review stages and work with all drafts for any particular IPCC report. How-
ever, it does not work with multiple IPCC reports at once. You need a separate RCtool 
data base for each IPCC report.
 
Following modular guide describes the use of RCtool from a particular user perspective 
pursuing a particular goal. There is no need to read everything. 
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This guide will always assume that you have installed RCtool and made ready as de-
scribed in the installation tutorial of the file ‘ RCtool Read Me.pdf’ .7

 This file comes with every release of RCtool and is also available from the home page of RCtool7
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Using RCtool to read and compare drafts
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .8

 RCtool fed with the meta data on a draft offers a flexible Table Of Content (TOC) 
mode in which you can conveniently jump to any listed item in the PDF of that 
draft. In the top left corner of the RCtool window you see a pop-up menu showing the 
current mode, i.e. ‘Edit Mode: Standard’:

Use this pop-up menu to switch to mode ‘Table of contents’:

Once in that mode you have a flexible TOC at your fingertips that allows you focus on 
particular elements such as FAQs or Cross-Chapter Boxes, figures, sections etc. of any 
of the four drafts, i.e. from ZOD, FOD, SOD, and FGD. For the SR1.5 the TOC for all 
drafts looks as follows, i.e. it starts with the ZOD followed by FOD, SOD, and FGD:

 This file comes with every release of RCtool and is also available from the home page of RCtool8
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Any element listed is a “link” or button, when clicked brings you immediately to the right 
location in the associated PDF. 

The strength of RCtool is however with its ability to focus on particular aspects. At the 
top you find several pop-up menus that allow you to narrow your focus: 

 

Say you wish to focus on FAQs. Simply choose FAQ from the Elements pop-up menu

You will get a list of all FAQs as they evolved from draft to draft. You can further narrow 
the focus by choosing from pop-up menu Draft the FGD:

Resulting in following view showing you to what the FAQs evolved from the FOD (partly 
shown above) into the final FAQs of the FGD (shown below):
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Another example is focusing on the evolution of the main structure, i.e. sections at level 
1 of a chapter, say chapter 2. Set such a focus by using pop-up menu ‘Elements’ to fo-
cus on element ‘Section’: 
 

Then set ‘Chapter’ to 2, ’Show depth’ to 1 (top level), and set Draft back to ‘ALL’ (the se-
quence does not matter at all). The settings should then look similar to this: 
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The resulting view gives you an overview how the main structure of the chapter evolved: 

Remember, you can quickly and efficiently jump to any of the sections listed in all the 
referenced PDF’s using one of the PDF readers supported by RCtool by clicking on the 
wanted element. In cases where actual figures are appended to the text, e.g. SR1.5 
ZOD, the page numbers to the right allow you to jump to the actual figure in the annex 
as well as the location in the text where the figure is introduced. 

RCtool guide /10 67



Using RCtool to manage Review Comments
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .9

RCtool stores Review Comments, Author Responses, and RE Annotations. The 
data are present at all times, i.e. stored in the underlying RCtool data base, yet may be 
currently hidden, depending on RCtool’s state. RCtool offers different views to the un-
derlying data base, allowing the user to focus on particular aspects. A great 
strength of RCtool.

For each role of the user, RCtool offers different basic modes:

• Edit Mode: Standard  for REs and other users to enter annotations on Review 
Comments, e.g. assigning a priority to the Review 
Comment. All data entered in that mode form the so-
called RE Annotations, which include the RE Evalua-
tions of the Author Responses.

• Edit Mode: Hide Authors for REs a mode that is basically the same as ‘Edit 
Mode: Standard’. The only difference is that Author 
Responses are not shown, which is mostly then use-
ful, when Author Responses are not yet available.

• Edit Mode: Authors for authors to enter Author Responses

• Edit Mode: Show History for all users resolving conflicting Author Responses or 
RE Evaluations as may result from collaboration

• RCtool Settings for all users to view and set settings of RCtool

• Page statistics for every user wishing to generate statistics on the 
Review Comments, i.e. statistics on how many Re-
view Comments were received for each page. The 
statistics can be exported and histograms drawn using 
e.g. R.10

• Reviewer statistics for every user wishing to generate statistics on the 
reviewers, e.g. statistics on how many Review Com-
ments each reviewer made. The statistics can be ex-
ported and histograms drawn using e.g. R.9

 This file comes with every release of RCtool and is also available from the home page of RCtool9

 R is an open source statistics package available from https://cran.r-project.org10

RCtool guide /11 67

https://cran.r-project.org


In addition to above modes, each offered within a particular view , there are many more 11

modal views available, e.g. for administrators.

By default RCtool offers a set of menus, the standard RCtool menus. RCtool offers 
also a set of extended menus in the so-called Pro mode for advanced usage . The Pro 12

mode menus contain additional menu commands and offer an access to the standard 
FileMaker menus.  For several commands also offered in the RCtool menus, it may be 13

of advantage to consult the FileMaker help information, since these commands are not 
customized and simply offer FileMaker’s standard functionality.

 At any time RCtool shows typically the Review Comments of only a single 
draft. Depending on which Review Comments have been imported into the data base, 
comments for the ZOD (Zero Order Draft or Internal Draft), the FOD (First Order Draft 
reviewed by Experts), the SOD (Second Order Draft reviewed by Governments and Ex-
perts), and the FGD (Final Government Draft reviewed by Governments, focusing on the 
SPM) can be viewed. The pop-up menu in the top left corner offers not only the possibil-
ity to switch among the four drafts, but offers also an option to show all comments 
from all review stages at once (mixed mode):

     

To remind the user clearly of this mode, red colours highlight this f 

 In FileMaker terminology such a view is also called a Layout11

 Activate this mode by menu command ‘Help -> Set Pro Mode -> On’. Deactivate it by ‘Help -> Set Pro 12

Mode -> Off’.

 Switch to the standard FileMaker menus by ‘Pro -> Use FileMaker menus’. Return to the RCtool menus 13

by ‘Scripts -> About & Help -> Set Pro Mode -> On’ or ‘Scripts -> About & Help -> Set Pro Mode -> Off’.
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            reminds you that the current FileMaker selection shows all 11076 Re-
view Comments that are currently in the RCtool data base in a mixed mode 
(regardless of the draft which the comments pertain to)



RCtool offers in its standard mode or view many elements. The following describes 
their basic functionality and purpose: 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Number of the currently selected Review Com-
ment out of all currently viewable (selected) 
comments: Type a Review Comment’s number 
to view it.

Element the Review Comment 
references, e.g. section or figure.

Tip: Hover the mouse over this 
field to see the title. E.g. if this 
field contains 1.2.1, the title of 
section 1.2.1 is displayed

Review Comment

Author Response

RE Annotation

«Mode» menu:
click to switch to 
another mode 
(view) of the data

The second row is for the comparison 
draft, here the SOD (looking forward from 
the FOD). The black button to the right 
shows which draft the FOD is compared 
to and is at the same time a button, if 
clicked opens the SOD PDF at the com-
parable page. E.g. if the comment refer-
ences section 1.2.1 or Figure 2.1, the 
SOD PDF is opened at the page with a 
section 1.2.1 or a figure 2.1 (may be an-
other than the wanted one).

Link to the FOD 
PDF: Click to 
open the PDF at 
the referenced 
page

The vertical black 
line in the margin 
shows the cur-
rently selected 
comment

Move to next Review 
Comment

Menu to enter the RE Evaluation of the Author 
Response

Move to previous 
Review Comment

Shows the current 
draft and allows to 
select another one

Open another
window, e.g. 
to display 
other Review 
Comments



A more zoomed in view: 
 

 
Other elements:
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Chapter number, which 
may be SPM or ALL, 
the latter if comment 
refers to entire report

The number of the Re-
view Comment (is 
unique within the draft)

The page and 
line number of 
the begin of the 
referenced text 
passage

The page and 
line number of 
the end of the 
referenced text 
passage

The page and line number of the begin of the refer-
enced element in the comparison draft. E.g. section 
1.3.1.1 starts in the SOD on page 36 at line 37. Hint: If 
these values automatically guessed by RCtool are 
wrong, you can overwrite them by entering the correct 
values (menu command ‘Helpers -> Enter page and 
line for comparison draft…’). The field to the right 
(without frame) may adjust its value accordingly and 
change to the section in which the comparison text 
passage actually lies.

The referenced text passage starting on page 23 
at line 53 and ending on page 23 at line 54 lies 
within section 1.3.1.1. Hovering with the cursor 
over this field shows also the title of this section.

This is comment 32 in the current File-
Maker selection. Hint: If the current 
comment selection shows only com-
ments from the same reviewer, this is 
the reviewers’s 32nd comment.

78 comments are currently shown, i.e. are 
in the current FileMaker selection. Hint: If 
the current selection shows only com-
ments from the same reviewer, she 
provided a total of 78 comments

A total of 3147 comments on the FOD 
are currently in the RCtool data base 

Click to toggle current selection for 
the hidden, i.e. currently shown 
comments will be hidden, currently 
hidden comments will become 
selected and visible

3069 comments are currently 
NOT shown, i.e  are NOT in 
the current FileMaker selec-
tion, yet are still in the RCtool 
data base. Hint: Click button 
‘Show All’ to no longer hide 
any comments.



Note, the elements and tools described above offer also context specific help when 
hovering with the cursor over them.

Searching comments
 RCtool offers numerous menu commands and features to search for particular 

Review Comments, Author Responses, and/or RE Annotations and to sort them. These 
features are offered via menu ‘Comments’. Many commands available in that menu offer 
the same basic functionality as that of any FileMaker data base. Thus any FileMaker tu-
torial can help you here. Understand simply that a Review Comment is called a record. 
Similarly every Author Response or RE Annotation is also called in the FileMaker termi-
nology a record (albeit each of a different type).

RCtool offers Quick search (top right). While this search is convenient, it may not always 
be the most efficient method, since it searches in all fields and all records of the entire 
data base. If you know that you are only interested in finding review comments that 
mention a particular keyword, say ‘Anthropocene’, then it is far more efficient to use the 

 Advanced search instead of the Quick search feature. The advanced search offers 
you an empty record in which you can simply type your search criteria into the field 
where you wish to find the wanted information. E.g. to find all comments where the re-
viewer mentions ‘Anthropocene’ you simply type this word into the Review Comments 
section: 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Then perform the search (click on Perform Find in toolbar or simply press Enter). If you 
wish to add another search criteria, e.g. all comments on ‘Anthropocene’ from a particu-
lar reviewer, say one from Botswana University, then enter also Botswana into the top 
left corner, that is the field where you normally find the reviewer’s name and affiliation. 

Only then perform the search, which will find all Review Comments anywhere where the 
word Anthropocene is contained in the comment AND the reviewer’s data contains any-
where the word Botswana. It may well be that there is no such comment present in your 
data base, since no reviewer from Botswana has mentioned the word Anthropocene in 
her/his comment. RCtool will inform you about this fact and allow you modify your 
search criteria or give up and return to the normal browse mode. Note, these searches 
are not case sensitive, yet typos matter of course. Search criteria need not be entire 
words, but can be just the beginning. E.g. ‘climat’ finds ‘climate’, ‘climatic’, ‘climatology’ 
etc. But ‘limat’ finds none of those. Remember, any logical AND is specified by entering 
the search criteria within the same so-called search record as shown above.

Say you wish to find all comments that mention SPM or “Summary for Policymakers” or 
“Summary for Policy Makers” (note the latter is not written in the IPCC tradition). The 
search criteria is then based on two logical ORs, which connect the three variants of 
mentioning the same thing. Such OR searches are built by using several search records 
(requests), not only a single one as used above with the AND search criteria. The ad-
vanced search criteria for this example looks then as follows using three different search 
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records (requests) made by duplicating the first, the third one being edited at the mo-
ment of this snapshot: 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 RCtool does also allow you to constrain a set of comments as resulting from a 
previous search or to extend such a set. Note, the menu ‘Comments’ becomes ‘Re-
quests’ when you are setting up an advanced search (FileMaker calls this the “Find 
Mode”) and you find in this menu the commands that allow you to constrain or extend 
the current set. Simply activate Find Mode from any current set, enter your search or 
omit criteria and instead of performing the search choose menu command “Requests -> 
Constrain Found Set” or “Requests -> Extend Found Set”. 
 

 RCtool offers a wealth of menu commands that are dedicated to particular and 
common advanced searches. E.g. the menu command ‘Comments -> Find comments 
-> Find critical comments...’ offers to find quickly potentially critical comments that 
may deserved particular attention at the begin of a review round. The submenus ‘Com-
ments -> Find comments’ and ‘Comments -> Show comments’ offer many more such 
commands that let you manage your data conveniently. You can also customise search-
es and save commonly used searches (menu commands ‘Comments -> Saved Finds -> 
Save Current Find…’ and ‘Comments -> Saved Finds -> Edit Saved Finds…’). 
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 You can revisit any search you just made by using menu command ‘Comments -> 
Modify Last Find’. This helps also to learn about the searches that RCtool already pro-
vides and makes it also possible for you to customise or extend any current search, may 
that be your own search or one that is provided by RCtool.

There is only one thing to remember well when defining your own advanced searches: 
Your RCtool data base accumulates your work and typically contains data from several 
review rounds, i.e. multiple drafts. A search that is targeted only at the comments within 
the current review round, say the FOD, such a search needs therefore to be constrained 
to the FOD. RCtool offers you this constrain by default when setting up an advanced 
search. However, if you wish to add additional criteria, e.g. to define a logical OR as de-
scribed above for the SPM example, make sure you keep that constrain in every search 
record, e.g. by duplicating the search record instead of creating an empty one from 
scratch while defining the search. In fact every example shown above uses an AND cri-
teria by having FOD (or SOD) in the top right corner of each search request. Searching 
for ‘Anthropocene’ in all review rounds would require to use in the top right corner noth-
ing, which is shown as greyed out ALL:

 

This is only the default in advanced search when first selecting ALL in the top left corner. 
In all other cases, say you are working with the FOD, that corner looks like this: 
 

 

and you can’t choose ALL from the offered pop-up menu: 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To accomplish that nevertheless, simply renew your Find Mode activation by repeating 
the shortcut (Cmd^F on Macintosh). Alternatively create a new request (click on toolbar 
‘New Request’ and delete the first you obtained by default. The window should then look 
similar to this one:

Clicking ‘Perform Find’  or alternatively choosing menu ‘Requests -> Extend Found Set’ 14

or ‘Requests -> Extend Found Set’ produces then as you wish the wanted set of Review 
Comments. 

 or pressing Enter or choosing menu ‘Requests -> Perform Find’14
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Entering Author Responses
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .15

1) Choose the draft  you want to work with, e.g. the SOD:

        

2) Find the comments not yet responded to  by choosing menu command ‘Com-
ments -> Show comments -> without Author Responses’:

3) Switch to mode ‘Edit Mode: Authors’ if RCtool should be in another mode. Your 
RCtool window should then look similar to this: 

 This file comes with every release of RCtool and is also available from the home page of RCtool15
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4) Enter in the green area your Author Response : This may entail to first jump to 
the text passage by clicking on the black button in the top right corner, which should 
open the PDF of the SOD at the referenced location. Having considered the com-
ment next enter your response. Best do that with the Decision, say you intend to ac-
cept the suggested change: 
 

  
Alternatively you can also type the letter A in the main field (labelled ‘Expl:’) and 
press Enter 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That will also enter your Decision in the middle top as if you would have made the 
choice via aforementioned pop-up menu. 
 
Then of course do the change in the Word file for the next draft, in this case the 
FGD. You may return to RCtool to add further texts to your response. That would be 
particuarly necessary if you would have rejected the comment. Remember, whatever 
you enter here in the green response area will later be made publicly available. 

5) Proceed to your heart’s content with other not yet responded to comments. 

Once you have finished your work it may be wise to make a backup, in particular after a 
long working session (see section «Making a backup»). You may then also share your 
work with colleagues. Say your chapter scientists collects all Author Responses. You 
may sending her or him the entire data base using the menu command ‘File -> E-mail or 
Export for collaboration -> E-mail data base to a colleague...’. 

 
Alternatively, in particular if that file should be too large, you may also send the result of 
your efforts by using a spreadsheet. Then choose menu command ‘File -> E-mail or Ex-
port for collaboration -> E-mail spreadsheet with Author Responses to a colleague...’.

How the receiver of this e-mail can handle your output and to merge it with her or his 
work is described under section «Collaboration». 

Entering RE Annotations
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The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .16

1) Choose the draft  you want to work with, e.g. the SOD:

        

2) Find the comments not yet annotated  by choosing menu command ‘Comments 
-> Show comments -> without RE evaluations’:

3) Make your RE Annotation . Typically you start by setting a priority . Then you 17

may wish to enter some considerations by typing those into the large blue rectangle. 
If you already have received the Author Responses you can finish your RE Annotation 
by also making the evaluation of the Author Response. Do this with the menu in top 
left corner.

4) Proceed to your heart’s content with other comments you have not yet looked at.

Once you have finished your work it may be wise to make a backup, in particular after a 
long working session (see section «Making a backup»). You may then also share your 
work with colleagues. Say one of your RE colleagues collects all RE Annotations for 
comparing notes, in particular relevant for critical comments. You may sending him or 
her the entire data base using the menu command ‘File -> E-mail or Export for collabo-
ration -> E-mail data base to a colleague...’. 

 This file comes with every release of RCtool and is also available from the home page of RCtool16

 For those common choices is also a menu command available. See menu “Helpers -> Set priority to 17

‘xyz’”. This may come handy if you wish to use a shortcut for that menu command on your system. E.g. on 
the Macintosh platform you can use ‘Apple -> System Preferences... -> Keyboad -> Shortcuts -> App 
Shortcuts’ and enter there for RCtool every menu command with its shortcut for which you wish to use a 
shortcut. This comes very handy when having to process thousands of comments. I use on my Mac e.g. 
Ctrl^N for priority ‘Normal’, Ctrl^V for priority ‘Very high’, Ctrl^H for priority ‘High’, and Ctrl^E for priority 
‘Editorial’. But this all depends of course on your preferences, taste, and working style.
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Alternatively, in particular if that file should be too large, you may also send the result of 
your efforts by using a spreadsheet. Then choose menu command ‘File -> E-mail or Ex-
port for collaboration -> E-mail spreadsheet with RE Annotations to a colleague…’.

How the receiver of this e-mail can handle your output and to merge it with her or his 
work is described under section «Collaboration». 
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Collaboration
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .18

 Collaboration among members of a team are supported by RCtool in many ways. 
First collaboration is supported among team members who use RCtool. But collabora-
tion is also supported among team members where some colleagues use RCtool and 
others do not use RCtool. RCtool is then designed such that typically one RCtool user 
collates all contributions from the team by importing and merging them into a single RC-
tool data base. For authors this role may be taken on by a CLA or the chapter scientist 
(if the chapter has one) and for RE teams this role needs to be taken up best by a single 
RE. In the following the person collating the RCtool data is called the RCtool coordina-
tor.

The features supporting collaboration can then be grouped in two categories:

• Collaboration among RCtool users
• Collaboration between RCtool users and non RCtool users

Furthermore, all these collaborations consist of two parts each:

• Exporting a finished work to the coordinator 
• The coordinator importing and merging the received work

 To maximally facilitate the collaboration also in the case where data are shared be-
tween  RCtool and other techniques, e.g. Excel spreadsheets, RCtool provides means 
to generate a spreadsheet that is is easier to use than the spreadsheets provided by the 
TSU. This is particularly relevant for REs, since the TSU may provide spreadsheets that 
are designed to hold only Review Comments and Author Responses, but no RE Annota-
tions. To enable a smooth collaboration it is therefore beneficial that RCtool coordinators 
generate the needed spreadsheets for colleagues who prefer to work with spreadsheets 
instead of RCtool as soon as possible. However, this is not a prerequisite and RCtool is 
able to handle also other cases.

 
Generate a Review Comments spreadsheet for a colleague

 This consists of three steps to be done by the RCtool coordinator:  
 
(i) select the Review Comments (even if that should mean all comments), 
(ii) assign the responsibility to the selected comments using the colleague’s initials, and  
(iii) choose a menu command to generate the spreadsheet.

 This file comes with every release of RCtool and is also available from the home page of RCtool18
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Depending whether you generate the spreadsheet for a RE colleague or an Author col-
league, choose another menu command. For an Author colleague choose ’File -> E-mail 
or Export for collaboration ->  Export Review Comments to Excel for an author col-
league…’, 

or for a RE colleague choose ’File -> E-mail or Export for collaboration ->  Export Re-
view Comments to Excel for a RE colleague…’. 
 

  
A spreadsheet is generated in the RCtool work folder. That spreadsheet is also automat-
ically opened for inspection and/or further formatting to suit the purpose.

Note that additional columns have been added that were not present in the original Re-
view Comments file as you may have received once. All these additional columns facili-
tate collaboration and the later collation in a single RCtool data base. 

Once all is ready send the spreadsheet to the colleague and ask her or him to NOT 
change any columns, neither by sequence nor other rearrangements. If someone 
prefers to ignore some columns, it may help to hide those columns, but never delete 
them or move them somewhere else. No additional columns should be added either, un-
less they are added to the very right after the very last column generated by RCtool.

For a full understanding: Note, the spreadsheet structures RCtool uses for sharing data 
remains basically the same, yet the number of rows and hereby the data may differ de-
pending whether you generate the spreadsheet with the method described here or one 
described further below. As described under this section all currently selected Review 
Comments determine how many rows are written to the spreadsheet. Using the method 
as described in the section «Share a spreadsheet with a colleague», only those com-
ments are written to the spreadsheet for which you have actually entered as author ei-
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ther some Author Responses or as review editor some RE Annotations. 
Only if you have entered Author Responses and/or RE Annotations for all review 

comments, will the exported spreadsheets contain similar data. However, there may still 
be differences depending on whether some histories in Author Responses or RE Anno-
tations are present in your data base. Neither a history of Author Responses nor of RE 
Annotations is written to the spreadsheet if you use either ‘Export Review Comments to 
Excel for an author colleague…’ or ‘Export Review Comments to Excel for a RE col-
league…’. A history of Author Responses is only written to the spreadsheet when using 
either ‘E-mail spreadsheet with Author Responses to a colleague…’ or ‘Export RE Anno-
tations to Excel for sharing…’. Similarly a history of RE Annotations is only written to the 
spreadsheet when using either ‘E-mail spreadsheet with RE Annotations to a col-
league…’ or ‘Export RE Annotations to Excel for sharing…’. For more details on histo-
ries see section «Managing histories». 
 

E-mail data base to a colleague
 Sharing either your Author Responses or RE Annotations you have entered so far 

with another RCtool user is very simple and straightforward. RCtool even offers a single 
menu command to not only generate the needed file but also to generate an e-mail, at-
tach the file to that e-mail and offers the user the e-mail for editing and sending. Choose 
the following menu command to achieve this:

 
To avoid the e-mailing of large attachments, this process does not generate an exact copy of 
your data base. It deletes all Review Comments and retains only the data that correspond to the 
role of the user, i.e. if you are an author only Author Responses or if you are a RE only RE An-
notations will be retained in the file. Note, as of 1.8fc12 this feature is note yet implemented and 
attachments need to be sent in full size or then use a spreadsheet to share your work with a col-
league.  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Share a spreadsheet with a colleague
 RCtool supports also the sharing of data that you have produced using RCtool by 

using spreadsheets instead of the entire RCtool data base file (as described above). 
This method is also supported via a menu command that allows you to E-mail the 
spreadsheet right away. Following two commands support such sharing of your work 
with a colleague, depending whether your role is that of an author or a review editor: 
 

  

 

Alternatively you can also first simply generate the spreadsheet without E-mailing that 
directly. Use one of these commands to accomplish this:
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The exactly same spreadsheet is generated in the folder where the application RCtool 
resides. You can use that spreadsheet for whatever you want, but typically you would 
use that to share it with a colleague via E-mail or Dropbox or whatever arrangement you 
have decided to use within your team to share your work.

For a full understanding: Note, the spreadsheet structures to share data remains the 
same, yet the data may differ. As described under section «Generate a Review Com-
ments spreadsheet for a colleague» all currently selected Review Comments determine 
how many rows are written to the spreadsheet. Using the method as described in this 
section, only those comments are written to the spreadsheet for which you have actually 
entered as author either some Author Responses or as review editor some RE Annota-
tions.  

Only if you have entered Author Responses and/or RE Annotations for all review 
comments, will the exported spreadsheets contain similar data. However, there may still 
be differences depending on whether some histories in Author Responses or RE Anno-
tations are present in your data base. Neither a history of Author Responses nor of RE 
Annotations is written to the spreadsheet if you use either ‘Export Review Comments to 
Excel for an author colleague…’ or ‘Export Review Comments to Excel for a RE col-
league…’. A history of Author Responses is only written to the spreadsheet when using 
either ‘E-mail spreadsheet with Author Responses to a colleague…’ or ‘Export RE Anno-
tations to Excel for sharing…’. Similarly a history of RE Annotations is only written to the 
spreadsheet when using either ‘E-mail spreadsheet with RE Annotations to a col-
league…’ or ‘Export RE Annotations to Excel for sharing…’. For more details on histo-
ries see section «Managing histories». 
 

Import a colleague’s work into the master data base
 The import depends in which form your colleague has sent you her or his work. Two 

types of data are ready to be imported easily. You received:

• an entire RCtool data base

• a shared spreadsheet that holds the colleague’s work (Author Responses or RE 
Annotations)
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In both cases use the submenu ‘File -> Import from collaboration -> ‘. In case of Author 
Responses use one of following two menu commands:

1. ‘Import some Author Responses from a RCtool file…’  
 

 

2. ‘Import some Author Responses from a shared spreadsheet…’  
 

In analogy to above instructions use one of following two menu commands to import RE 
Annotations data:

1. ‘Import some RE Annotations from a RCtool file…’  
 

2. ‘Import some RE Annotations from a shared spreadsheet…’  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You will be asked from which file to import the colleague’s data. Select either the RCtool 
file or the shared spreadsheet, depending which menu command you used.

 Whenever you import a collaboration spreadsheet, the data are not imported directly. 
This means they are not merged directly into your main RCtool data base as contained 
in file RCtool-main. Instead the data are imported into a quarantine environment, 
which is also offered by the RCtool-Main data base. There you can inspect the data, edit 
or discard them, reimport them, and finally if you are happy with the data, transfer all or 
only some for actual use into your main data base. The quarantine environment looks 
similar to this: 
 

 

At the bottom of the table (footer) is the colleague’s spreadsheet file shown from which 
you intend to import her data. You should see there the file you have selected in the 
previous file selection dialogue while entering the quarantine.

The white button on the top imports the data from the spreadsheet. Note, this button al-
ways purges first all data from the quarantine before importing the ones from the file 
shown in the footer at the bottom. The red button deletes all data in the quarantine, the 
orange button only the currently selected row. The area at the button showing the file 
name is also a button. You can click it anytime to select another file to be used for sub-
sequent imports.

The green button serves to really use the data, i.e. to transfer them out of the quarantine 
into the main data base. Click this button once you decide to use the data that are cur-
rently shown in the table. Hereby any entries that are identical to those that are already 
in the main data base will be ignored and only those data that are unique – either Author 
Responses or RE Annotations – will actually be stored in the main data base. This sup-
ports an easy, yet selective merging of the data and makes it possible to repeatedly im-
port work from your colleagues and accumulating all data as you receive them without 
creating any redundancy. If some of these data were actually modified between two im-
ports, RCtool detects this and keeps multiple entries in such a case. Those multiple en-
tries, e.g. several Author Responses to the very same Review Comments, then a so-
called history is generated by RCtool. How to handle such histories is described under 
section «Manage histories». How to clean-out the data base should you have acciden-
tally created duplicates is described under section «Resolving conflicts from redundan-
cies (duplicates)».

For a full understanding: Note, quarantine data cannot be restored from a backup. How-
ever, as long as you work with the same ‘RCtool-main' file the quarantine data are kept 
fine until you delete them by some button click. Note, all quarantine data are deleted be-
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fore an import, i.e. as soon as you click on the white button all current data are deleted 
and replaced by the newly imported ones. Therefore, should you have invested time by 
editing the data in the quarantine, never leave those data there without first getting the 
edited data into the main data base. Otherwise you risk to lose your work, e.g. should 
you inadvertently click on the white button. Once in the main data base, you can still edit 
those data there. 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Managing histories
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .19

 Normally you see per Review Comment either none or only a single Author Re-
sponse and/or none or a single RE Annotation . However, RCtool supports multiple 20

Author Responses and/or multiple RE Annotations for a single Review Comment. 
First, since Author Responses are to be made by the entire author team, multiple re-
sponses and/or notes may arise from multiple authors for the very same Review Com-
ment, while the final Author Response is developed. Similarly, as a RE team you may 
decide to look at critical comments independently by each RE, again leading to several 
evaluations that may not always concur right away and may therefore lead similarly to 
multiple RE Annotations for the very same Review Comment. What results is a so-called 
1:n relationship between Review Comments and Author Responses or RE Annotations, 
respectively. Whenever n becomes bigger than 1 means, there is a history present for 
that Review Comment, either an author history or a RE history. Although the end prod-
uct IPCC rules need will be a single Author Response or single RE Annotation for every 
Review Comment, histories have proven to be helpful in supporting author and RE 
teams in their work. This is exactly where RCtool comes in and supports teams in their 
collaborative efforts (see also section «Collaboration»).

In the standard modes the presence of a history is indicated by a little pink square la-
belled ‘H’ (for history) in the top right corner of the respective sections for Author Re-
sponses and/or RE Annotations: 
 

                                             

 Click on these pink squares (or use mode pop-up menu to switch to ‘Edit Mode: 
Show History’) to see the actual history. RCtool offers sophisticated tools to deal with 
a history. E.g. RCtool offers search commands to find all comments for wich there exists 
an author or RE history (menu commands “Comments -> Show comments with an au-
thor history” for author histories or “Comments -> Show comments with a RE history” for 
RE histories, respectively).

 This file comes with every release of RCtool and is also available from the home page of RCtool19

 In data base terminology this would be called a 1:1 relationship in contrast to a 1:n relationship20
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Managing author histories
 History management is particularly useful for authors responding to Review 

Comments that pertain to the entire report. For the latter it is likely that several Au-
thor Responses arise, since multiple teams independently respond to the same Review 
Comment as they deal with only that part of the comment as it affects their respective 
chapter (see figure below for an example). RCtool allows to edit these histories and to 
unify the responses, by merging or giving preference to a particular response. To see 
the history click either on the pink history square (see above) or switch the mode to ‘Edit 
Mode: Show History’. In that view/layout you can see all Author Responses in a scrol-
lable list “attached’ to the original Review Comment (see example below). To the right 
you find buttons that allow you to give a particular response priority (check mark) or 
delete some responses (cross) or allows you to edit the contents, by copy pasting text to 
a single response, which is given priority (check mark) once the editing is complete. The 
following example shows a longer response and a shorter one from two authors, each 
from a different chapter of the same report SR1.5. The two responses could be merged, 
e.g. by copy pasting and inserting the second response in front of the first. 
 

 

 The green plus button can be used to duplicate the Author Response shown 
on the left serving as a basis for the final response. This will leave the history intact, 

RCtool guide /35 67



while an additional new response record is created at the top of the history and the re-
sponse selected (for deletion or other editing). This serves to create a final response 
merging all from the history by copy and paste plus editing with the intent to keep only 
that new response. If there is no need to merge content and you give preference only to 
a specific response currently not on the top, then promote that response to the top by 
clicking on the up arrow button.  If you wish to complete your work, e.g. by making 
a particular response as the final one, then click the check mark button. That will 
also add the phrase “ (for all C/LAs)” after your initials and the evaluation status should 
then show Done or Resolved (if it was previously Pending). Whether you prefer to delete 
the no longer needed Author Responses, e.g. by clicking on the red cross button or not, 
is not important. Without deletion a record is kept. Note, for the final use and publication 
only the topmost response is used.

To revert a finalisation, having perhaps second thoughts, you have two options: Either 
click on the phrase or then click on the little Defer button in the bottom left corner. This 
sets the status to pending, flagging this Review Comment for other authors. A dedicated 
menu command ‘Comments -> Show comments -> with a pending Author Response’ 
helps your colleagues to focus on those Review Comments they have still to come in as 
well to work on the Author Response and complete it to ready it for publication.

While the history mode shows only a single Review Comment at a time, it is possible to 
work on all review comments with a history by following this sequence of steps:

1 ‘Comments -> Show comments -> with an author history’
2 Switch to the history mode
3 Edit the history
4 Click on the next button (Mac Ctrl^<arrow down>) and repeat as from step 3
until finished

Once finished exit the history mode by clicking on the conspicuous red button in the top 
right corner labelled ‘Exit History Mode’.

 Back in the standard edit mode not finished Author Responses are charac-
terised by having in the top right corner a little orange square. To finalise such an 
Author Response, e.g. when it is pending, click on the orange square button to finalise 
the Author Response (does the same as the check mark button in the history mode). 
The little square becomes green and the evaluation status should then show Resolved 
(or Done). Again you can revert that action by clicking on the Defer button in the left bot-
tom corner. If the Author Response has already been finalized, you are asked for a con-
firmation.

Once all histories have been resolved, the dedicated menu command ‘Pro -> Scripts -> 
E-mail or Export for collaboration -> Export Review Comments to Excel for 
publication…’ generates a spreadsheet that can be used to publish the final Author Re-
sponses with their Review Comments.
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Remember, the many tools RCtool provides offer help when hovering with the cursor 
over them.
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Managing RE histories
Managing RE histories is very similar to managing an author history. Again RCtool helps 
you greatly to accomplish your task as a RE. 

For instance, RCtool detects when evaluations by REs are conflicting and marks such 
Review Comments with a conspicuous little square flag (dark brown with a red ‘C’ for 
Conflict). Ex.: 
 

                           
 
This square button indicates that there are conflicting RE evaluations present in the his-
tory for this comment. Indeed the second evaluation present made by RE ‘IE’ differs 
from the first: 
 

  
 

Here the entire history of above examples: 
 

Switching to the mode ‘Edit Mode: Show History’ allows to view the history and the RE 
team can decide how to resolve the issue. Typically the team will make efforts to concur 
on a particular evaluation with a particular rationale. That rationale is best entered in the 
Notes field. To give that work top priority click the up arrow button. To finalise a RE An-
notation click on the little dark square button with the ‘C’. The RE Annotation will then be 
marked in the Who field with following token ‘ (for all REs)’. This token is appended to 
the initials of the RE making the finalisation. 
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This is how above example looks after REs have agreed to merge the two arguments 
and then finalising the top entry: 
 

                                            
 

You can anytime easily revert that finalisation status by clicking on the phrase ‘(for all 
REs)’.

Going back the mode ‘Edit Mode: Standard’ we see first the same little brown square 
with the red ‘C’, now in the top right corner. Additionally a second little green square ap-
pears left of the date and time of the finalisation:

 

It shows the overall status of the RE Annotation where 

green means, all is ok with that comment, 
orange there are issues, but they may be tolerable, 
red critical issues are present, e.g. if REs conclude that a Review Comment 

with a high or very high priority has not been addressed by the authors in a 
satisfactory manner. 

If all REs have fully concurred in case of multiple evaluations, i.e. a history without any 
conflicts, then the two square flags show an identical colour. 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The presence of the left square is then flagging only the status of being finalised. Simi-
larly the case where no history is present, yet the RE Annotations have been finalised: 

 

 
 

This second little square flag on the left is particularly helpful in cases where REs have 
made differing evaluations, in particular when evaluating some of the more critical com-
ments. Then the little brown square flag to the very right shows only the red ‘C’ (for con-
flicting evaluations). The left square also informs about the fact that the RE Annotation 
has been finalised: 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Some of the square flags explained above serve also as buttons, e.g. to finalize conflict-
ing RE evaluations click on the the little brown square flag showing a red ‘C’. Remem-
ber, the many tools RCtool provides offer help when hovering with the cursor over them. 
No need to remember all of above.

Obviously red flagged RE Annotations with even conflicting RE evaluations require par-
ticular attention and care by the RE team. To find such Review Comments again RCtool 
offers dedicated menu commands. E.g. the latter can be immediately selected by choos-
ing menu command ‘Comments -> Show comments -> that are red (very high priority)’:
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Making a backup
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .21

 Your RCtool data base is stored in the file ‘RCtool-main’.  This is a precious file. You 22

can make anytime a backup from all your data by choosing the menu command ‘File -
> Backup and Updating -> Backup dat abse RCtool (main, textlinks)’:

This will create a backup not only from your main data base, i.e. ‘RCtool-main’ where all 
your responses or annotations are stored, but also of the so-called textlinks, i.e. the the 
meta data on the structure of the draft (table of contents) as stored in ‘RCtool-textlinks’.

The backup files are exact copies of what you have at the moment when you make the 
backup. The backup files are stored in the subfolder ‘RCtool data archives’ within your 
RCtool work folder that came with the release (see ‘ RCtool Read Me.pdf’ for details).

The backup files are named by their source and the data and time of the backup is ap-
pended to the file name in big endian format. The backup may then look similar to this: 
 

 
Note, these files may get large. Note also that a backup is made automatically each time 

 This file comes with every release of RCtool and is also available from the home page of RCtool21

 This file has either the extension .fmpur if you work with the standard RCtool software. Otherwise, i.e. if 22

you work with ‘RCtool for FileMaker’, then the extension is ‘.fmp12’.
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you export some data, in particular when you do the latter in replace mode. Since this 
may result in using a significant amount of disk space it is recommended to delete su-
perfluous backups from the subfolder ‘RCtool data archives’ from time to time.

Note also, the files RCtool-main and RCtool-textlinks contain not only data, but also the 
functionality of the data base. The application RCtool itself contains not the RCtool spe-
cific functionality, but only the generic data base functionality as contained in FileMaker 
and as needed by the RCtool specific data base functions. Any backup stores therefore 
not only your data, but also the RCtool data base functionality. You can store only the 
data separate from the RCtool data base functionality. For this end you can use the ar-
chiving functions as also offered in RCtool (menu ‘File -> Arching’, see section «Ar-
chiving RCtool data»).

Restoring your RCtool data base from a backup or any other RCtool data base file is 
described under section «Restoring your RCtool data base». Restoring data selectively 
is described under section «Importing data from another RCtool data base». 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Restoring your RCtool data base
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .23

A RCtool data base can easily be restored from various sources. A typical case is 
restoring from a previously made backup (cf. section «Making a backup»). You are invit-
ed to do that when you start from a new copy of RCtool, e.g. after downloading an up-
date for a new version and launching that new RCtool for the first time. 

                

Clicking on button ‘Updating’ triggers a restore process. 

 Whatever reason you have for restoring, it is important to know that you can 
restore anytime your precious RCtool data. They represent possibly a lot of work you 
have invested. The RCtool data base is designed to provide maximal safety for your 
work and data.

Instead of restoring from a previous backup, you can restore your data also from 
spreadsheets. That is a bit more elaborate to do, but this offers sometimes more flexibili-
ty, e.g. to massage the data in Excel before restoring them to RCtool. Moreover, the 
backups made to Excel files are typically much smaller and are therefore more fit to be 
sent via E-mail. 
 

 This file comes with every release of RCtool and is also available from the home page of RCtool23
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To restore from a previously made backup simply choose menu command ‘File -> Back-
up and Updating -> Restore main data from backup or previous version (update)…’ as 
shown above and follow the instructions.

You are asked in the standard open file dialogue to select the backup file. Make sure 
you choose the wanted file and that it is a of the right kind, i.e. it is a RCtool-main back-
up file. You find a hint on what kind of file is expected at the top in the middle of every 
file selection dialogue.

At the end of updating you get a little summary of the content of your data base similar 
to this: 
 

            

This means there are 11,031 Review Comments, 6,981 Author Responses, and 1,190 
RE Annotations in total present in your data base, given as a number triple delimited by 
a vertical bar (‘|’). The sum of these, the so-called 19,202 records is given in the paren-
theses behind each triple. Below you get how these records distribute for all four drafts, 
a triple for the ZOD, FOD, SOD, and FGD each, again each time followed by a record 
total in parentheses. The legend at the bottom is a reminder how to read the sequence 
of numbers for each number triple. Given you started from an empty data base, this 
means all those 19,202 records were restored from the backup. The old data can now 
be used exactly as they were in the new RCtool offering a new functionality.

Understand that only the data are restored, not the data base functionality. The latter 
cannot be restored and is stored permanently in the data base file. Should you have a 
license for FileMaker Pro then you can also modify and customise the data base func-
tionality. However, in the freely available RCtool this is not possible. This is why you 
have to replace the old obsolete file ‘RCtool-main’ with the new one when updating to a 
new version of RCtool.

Note also, a restore always restores also all RCtool settings, settings that may have 
caused problems in the past and/or may cause some now. If you suspect such difficul-
ties you can easily click the button ‘Factory Reset’ in mode ‘RCtool Settings’ to resume 
an initial factory state of all settings. IMPORTANT: Note, this may require to choose 
your report and preferred chapter once again.
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If you wish to restore only some of your data, say either only Author Responses or only 
RE Annotations, then you need to use other techniques, which RCtool offers as well 
(see section «Importing data from another RCtool data base».

The file ‘RCtool-textlinks’ can also be restored from a previously made backup. 
Choose menu command ‘File -> Backup and Updating -> Restore textlinks data from 
backup or previous version (update)…’  
 

You are asked in the standard open file dialogue to select the backup file. Make sure 
you choose the wanted file and that it is a of the right kind, i.e. it is a RCtool-textlinks 
backup file. You find a hint on what kind of file is expected at the top in the middle of 
every file selection dialogue.

Note, the updating process you are offered during first time use of RCtool, notably when 
updating to a new version, employs the same techniques. It uses both of above de-
scribed restore processes, i.e. it simply calls each restore command for your conve-
nience one by one, first for RCtool-textlinks and then for RCtool-main.

It may also be that during a restore you encounter warnings about duplicates (redun-
dancies). Find more on how to handle these situations in section «Importing data from 
another RCtool data base» and «Resolving conflicts from redundancies (duplicates)».
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Importing from another RCtool data base
 
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .24

 This import technique allows you to import selectively either Review Comments , 25

Author Responses, or RE Annotations from a RCtool file . Note, RCtool Settings 26

cannot be imported in such a manner. RCtool Settings are only imported during a 
restore (section «Restoring your RCtool data base») or update (section «Updating RC-
tool», ‘RCtool Read Me.pdf’).

 To selectively import either Author Responses or RE Annotations from another 
RCtool data base file perform following steps: 

1) Ready the RCtool file (typically a RCtool-main file) from which you wish to import 
by making sure the parent folder holding the file is “blessed”

2) Choose the appropriate menu command, depending on the kind of data you wish 
to import, i.e. either Review Comments, Author Responses, or RE Annotations

On step 1: You can choose any file from any folder with the standard file selection dia-
logue. However, the import succeeds only as long as the parent folder of the file from 
which you wish to import has also two files present: ‘RCtool-main’ and ‘RCtool-
textlinks’.  27

Those files are small and contain no data, they just need to be FileMaker files having 
the correct names and being present. Once the two files are present, you can say the 
folder is “blessed” for any importing and restoring of any RCtool files that reside in it. As 
released the subfolder ‘RCtool data archives’ is already “blessed” and contains these 
two files. Thus it is recommended to use this folder by first choice. For any other folder, 

 This file comes with every release of RCtool and is also available from the home page of RCtool24

 The menu command needed to import Review Comments is only available in the so-called Pro mode 25

from the submenu ‘Pro -> Scripts -> Import data -> Import Review Comments from a RCtool file…’. Pro 
mode can anytime be activated by choosing menu command ‘Help -> Set Pro Mode -> On’.

 Files you can import from are characterised by having the extension .fmpur (free RCtool) or .fmp12 26

(FileMaker RCtool) and are in essence some copy of a RCtool-main file. Note, it does not matter whether 
the file you wish to import from has been sent to you by a colleague or resulted from a backup or was 
created by duplicating your RCtool-main file by using the Explorer (Windows) or Finder (Macintosh). It 
does also not matter by which backup method the file was created, i.e. whether you have executed from 
within RCtool an actual backup command or whether that file was generated automatically by RCtool’s 
auto backup feature. All these files are identical in their structure but not necessarily in the data they store 
and can therefore be used either to restore all your data or to selectively import from them.  

However, in some cases incompatibilities may arise when trying to import from RCtool files that 
were generated by an older version of RCtool.

 Extensions are either .fmpur (free RCtool) or .fmp12 (licensed FileMaker variant) 27

RCtool guide /47 67



however, make first a copy of the two files  ‘RCtool-main’ and ‘RCtool-textlinks’ from the 28

folder ‘RCtool data archives’ and move each copy to that extra folder while making sure 
the file names match precisely. In this manner you can “bless” any folder in which you 
wish to store files from which you intend to import (or restore).

On step 2: Use the submenu ‘File -> Import from collaboration’ or in Pro mode23 the 
submenu ‘Pro -> Scripts -> Import data’. 

To import Author Responses choose following menu command ‘Import some Author Re-
sponses from a RCtool file…’: 
 

To import RE Annotations data choose following menu command ‘Import some RE An-
notations from a RCtool file…’: 
 

 

 In case you append data the import routines may detect so-called duplicates. 
In such a situation RCtool offers you two main choices:

Typically you choose to partially import and ignore any data that are redundant to those 
already present in your data base (button “Clean-out”). While the process first import-
ed all data – which resulted in the detection of duplicates – in the end this option will add 

 On the Mac those two files are marked by having a yellow label28
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only what is new and different by ignoring any redundant data. Alternatively you can also 
decide at this point to discard the import entirely (button “Delete”), e.g. should you have 
accidentally imported the same data twice or you prefer to defer the import to a later 
point, needing to check something first. If all data are new for the RCtool data base, 
then they are of course simply added.

Once the import has finished you get a report about what was done similar to this: 
 

                              

summarizing that from the 10 imported Review Comments only 6 were actually added to 
your data base, while 4 were ignored by RCtool and not inserted, since they were mere-
ly duplicates of Review Comments already present in your data base. 

Find further details on the handling of duplicates in section «Resolving conflicts from re-
dundancies (duplicates)».
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Importing data via Pro mode
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .29

Normally RCtool should be able to easily import data from the files provided to you. 
However, following commands from the standard RCtool menus

‘File -> Import Review Comments from spreadsheet…’ 
‘File -> Import Author Responses from spreadsheet…’ 

 
work only  if 30

(i) the files have a name known to RCtool, 
(ii) reside in the correct RCtool work folder, and 
(iii) have the proper structure. 

Since it may easily happen that a file name is not the expected or some colleague has 
altered the structure of a spreadsheet, any such modification suffices to cause RCtool to 
be unable to import the data with above regular import commands. Requirements (i) and 
(ii) can normally easily be fixed. But RCtool offers an alternative to overcome all of these 
import difficulties: Use a command from the submenu ‘Pro -> Scripts -> Import data’ 
available in the Pro mode of RCtool:

The Pro mode can be activated via the Help menu ‘Help -> Set Pro Mode -> On’. 

 This file comes with every release of RCtool and is also available from the home page of RCtool29

 The requirements (i) and (ii) are relaxed if the preference ‘Ask always for file’ is checked (see mode 30

‘RCtool Settings’)
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For each category of data that you can import there are four menu commands with an 
analogue functionality (explained below only for data category Review Comments):

 
Note, each group of four menu commands are related and differ only little. One differ-
ence is the type of file from which you wish to import the data. Two types are supported, 
the import from another RCtool file such as a backup , which must be a RCtool-main 31

file. Secondly you can import from an Excel spreadsheet file with or without multiple 
worksheets (extension .xlsx). Another difference is whether RCtool asks you first to se-
lect the file from which you wish to import or not (note phrase … from a RCtool file). 
And a third difference is whether the structure of the file you wish to import from is al-
ready known to RCtool or not (note phrase … from any RCtool file).

The following similar  menu commands serve to import from a RCtool-main file:32

a) ’File -> Import from collaboration -> Import <data kind> from a RCtool file…’33

b) ’Pro -> Scripts -> Import data -> Import <data kind> from a RCtool file…’
c) ’Pro -> Scripts -> Import data -> Import <data kind> from any RCtool file…’
 
In all three cases RCtool asks you to select the file with a file selection dialogue (note 
phrase … from a RCtool file). In cases a) and b) for a successful import the internal 
structure of the RCtool file you wish to import from must be compatible with the current 
version of RCtool. In case c) you are asked in an additional dialogue window to assign 
which data goes where (note phrase … from any RCtool file). This requires some ex-
pert knowledge about the inner workings of RCtool and should therefore only be used 
as a last resort. But this may be unavoidable if the RCtool file you wish to import from 
has internally an incompatible structure so that menu commands a) or b) yield not the 

 see section «Making a backup»31

 for <data kind> Author Responses and RE Annotations a) and b) have even identical functionality32

 This menu command is only available from the standard RCtool menus (not from the Pro menus)33
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desired result, e.g. because the RCtool file was generated by an older version of RC-
tool. As a rule of thumb, always try out first commands a) and b) before using c).

To import from a spreadsheet the following menu commands are very similar:

a) ’File -> Import <data kind> from spreadsheet…’34

b) ’Pro -> Scripts -> Import data -> Import <data kind> from a spreadsheet…’
c) ’Pro -> Scripts -> Import data -> Import <data kind> from any spreadsheet…’35

 
In cases a) and b) for a successful import the structure of the spreadsheet you wish to 
import from must be known to RCtool and compatible with the current version of RCtool. 
In case a) the file name must be known to RCtool and the file has to reside in the dedi-
cated RCtool work folder. In cases b) and c) the name of the file does not matter and the 
file can reside anywhere on your system. RCtool asks you to select the file with a file 
selection dialogue (note phrase … from a spreadsheet). In case c) you are asked to 
assign which data goes where (note phrase … from any spreadsheet). This requires 
some expert knowledge about the inner workings of RCtool and should therefore only 
be used as a last resort. This may become necessary if the spreadsheet you wish to im-
port from has been modified by a previous user, e.g. by deleting or rearranging columns, 
or has an incompatible structure, e.g. because the spreadsheet file was generated by an 
older version of RCtool. As a rule of thumb, always try out first commands a) and b) be-
fore using c).

 If you have to resort to case c) you should watch out that you always import 
the core data. 

Of highest priority are the data needed to make the relationships between all three 
data categories functional. They are:

‘RevStage’ data may not always be available. If available in the input, always import it. 
Otherwise you have been asked by RCtool to provide a value. Correct values are: ZOD, 

Review Comments RevStage Comment_No Chapter_Info

Author Responses RevStage Comment_No Chapter_Info RevCommID

RE Annotations RevCommID

 This menu command is only available from the standard RCtool menus (not from the Pro menus)34

 Note following menu command uses a quarantine and does in contrast to cases a), b), and c) not im35 -
port the data directly into the RCtool data base
     ’File -> Import from collaboration -> Import <data kind> from a shared spreadsheet…’
(see section «Collaboration», subsection «Import a colleague’s work into the master data base»).

RCtool guide /52 67



FOD, SOD, or FGD. ‘RevCommID’ combines ‘RevStage’, ‘Comment_No’, and ‘Chap-
ter_Info’ in a single field/spreadsheet column. If you can, always import ‘RevCommID’ 
but it may be missing, e.g. in source files containing Author Responses.

These are the additional core data you should import as well (key fields in bold):

Above tables list the field names as used by RCtool as of version 1.8.2 or later. 

The following screenshot illustrates the situation, an example where authors have modi-
fied the spreadsheet and you are trying to import nevertheless the author responses:

Review 
Comments

Comment Category fromPage, fromLine, 
toPage, toLine

Reviewer data etc.

Author Re-
sponses

Author_decision Author_Response Pending, Response_-
finalized

Author_responsibility, 
Last_change_author, 
Last_change_date_author, 
Extra_author_notes

RE Annota-
tions

RE_Priority RE_Notes RE_Evaluation RE_responsibility, 
Last_change_RE, 
Last_change_date_RE
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What would result in above case is a bad import where no Author Responses would be 
imported and an ID of the reviewer would show up in place of Author Responses. Thus 
you need to rearrange things until following assignment between the column headers in 
the input spreadsheet (named “Source Fields”, shown on the left) and the field names of 
the RCtool data base’s target fields (shown on the right) results:

Arrange by drag and drop the target fields up and down until the spreadsheet columns, 
in this example ‘Commentid’, ‘Chapter’, ‘Response’, ‘Responseby’, and ‘Responsedate’, 
match their target fields, i.e. in this example ‘Comment_No’, ‘Chapter_Info’, ‘Author_Re-
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sponse’, ‘Last_change_author’, and ‘Last_change_date’ . Some target fields are 36

greyed out. Understand they are fields for which RCtool automatically calculates a value 
and consequently no data can imported into them. 

The source fields shown above are merely the column headers as used in the source 
spreadsheet in the first row. It may be helpful to use the left and right arrows on the left 
of ‘Field Names’ to move to other rows in the source spreadsheet.

 

This may be necessary if column headers are written on multiple rows or if the column 
headers are not clear and only the actual data allow you to recognise what is actually 
contained in the respective spreadsheet columns.

As a rule of thumb, if you import from a RCtool file it is recommended to use for ‘Arrange 
by:’ the option ’matching names’ and work from there. Yet, you need to be aware that 
this does not automatically warrant that all core data are imported. Field names may 
have changed from the previous RCtool version. Make sure that all wanted data are ac-
tually imported by clicking between the source and target field pairs. To import the data 
check there is the little arrow shown for that spreadsheet column you wish to import.

As a second rule of thumb you should always import as many data as possible, given 
the data appear to be correct. Use the two tables given above to check that you are im-
porting the minimum of data needed by RCtool.

Once you have arranged everything as it should, simply click the button ‘OK’ to initiate 
the actual import.

 
How to correct for a bad import?
 
In case the import does not look as it should, e.g. data are garbled up or obviously end 
up in the wrong place, there is nothing lost, since RCtool offers several techniques to 
easily discard the last import and to resume the state before a bad import. However, not 
all import errors are obvious. To be on the safe side it is recommended to check for 
problems by using menu command ‘Comments -> Search for problems in data base’ or 
‘Pro -> Scripts -> Resolve conflicts -> Search for problems in data base’ if you have any 
doubts about a made import before continuing your work. Note the following in this con-
text:

 The field ‘Last_change_date’ as shown in this graph has been renamed to ’Last_change_date_author’ 36

in RCtool version 1.8.2 or later, for easier understanding when having to match source with target fields.
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First RCtool makes typically a backup of your entire data base before importing new 
data.  Thus your RCtool data base before the import should be safe.37

Secondly RCtool automatically deletes empty imported data and tests the just imported 
data for errors. If it detects serious errors, it offers you in many cases the option to dis-
card the entire import right away (see in this context also section «Resolving conflicts 
from redundancies (duplicates)»).

If you have imported from a spreadsheet use following commands from the submenu 
‘Pro -> Scripts -> Resolve conflicts’ to get rid of the just made import: 

1) Optional: Make a backup if none was made during the import to be on the safe 
side

2) Depending on the type of data you have badly imported choose either  
‘View Review Comments in table format’ or 
‘View Author Responses’ or 
‘View RE Annotations’

3) ’Find last imported spreadsheet data’
4) Check that the selected data are the ones you really want to delete
5) ’Delete all currently selected…’

 
In many cases another robust and convenient technique is to reimport the data and 
when asked whether to append or replace the data answer with ‘Replace’. This works of 
course only if the data you wish to import is complete and was not meant to append the 
imported data to the already existing data. If the data are Review Comments this is the 
most convenient technique to fix a bad import.

Another option is to discard the current ‘RCtool-main’ file in favour of a backup you have 
made just before the import. Normally RCtool makes for you a backup automatically.  If 38

such a backup file is available from your subfolder ‘RCtool data archives’ then quit RC-
tool, discard the current ‘RCtool-main’ file and replace it with the backup file. Rename 
the file to ‘RCtool-main.fmpur’  and relaunch the RCtool application.39

As last technique consists of finding the just imported data by some specific characteris-
tic in place of step 3 as described above. E.g. this may be necessary if you have badly 
imported from a RCtool file data by not properly assigning source to target fields. The 
typical case is an import of Author Responses or RE Annotations. First note that in the 
unsorted state (default) the just imported records are appended after any records that 
were present before the import. The data base marks Author Responses and RE Anno-

 This depends on the preference settings of the option ‘Always backup’ (see mode ‘RCtool Settings’)37

 This depends on the preference settings of the option ‘Always backup’ (see mode ‘RCtool Settings’)38

 or ‘RCtool-main.fmp12’ if you work with the FileMaker version of RCtool39
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tations records with a data base unique stamp hold in field ‘ID_Database’. If the records 
were imported from another data base, e.g. from a RCtool-Main file that you have re-
ceived from an author or RE colleague, then this field may contain a unique value which 
is different from that used by your RCtool data base. Searching for those records is all 
what you need to perform step 3. Following menu commands from the submenu ‘Pro -> 
Scripts -> Resolve conflicts’ may help you here:

‘Find Author Responses imported from RCtool file’
‘Find RE Annotations imported from RCtool file’

Perhaps you need to further refine your search and hereby repeat steps 3) and 4) until 
you have exactly selected all badly imported records. Then of course you are ready to 
proceed with step 5).

As a final check to make sure that your RCtool data base is in a fine state check the in-
ternal consistency of your RCtool data base as described in section «Check internal 
consistency of your RCtool data base».
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Check internal consistency of your RCtool data base
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .40

You can anytime check the internal consistency of your RCtool data base to ensure it is 
in a fine state. This is recommended notably before a phase when you intend to invest 
considerable work into it or after a difficult import. Following menu commands from 
menu ‘Comments’ or the submenu ‘Pro -> Scripts -> Resolve conflicts’ help you here:41

a) ’Search for problems in data base’

and depending on the case also

b) ’Find duplicate Review Comments’
c) ’Find duplicate Author Responses’
d) ’Find duplicate RE Annotations’

Command a) can detect inconsistencies such as conflicts in the primary keys of Review 
Comments, Author Responses, and/or RE Annotations or essential fields being empty. If 
this command finds no records, your RCtool data base is technically in good shape. 

Otherwise execute from submenu ‘Pro -> Scripts -> Resolve conflicts’ the menu com-
mand

e) ‘Fix current sets of Author Responses and RE Annotations’

Command e) fixes empty critical fields in Author Responses and RE Annotations and 
assigns proper values to those. If no such problems are actually present, this command 
is without effect and safe to use.

In some cases – in particular after an import having caused the difficulty – the best rem-
edy may be to resume a previous state of RCtool by discarding the imported data (see 
subsection «How to correct for a bad import?» in section «Importing data via Pro 
mode»).

Commands b), c), and d) report only on the presence of duplicates. Fix such redundan-
cies as described in section «Resolving conflicts from redundancies (duplicates)».

 This file comes with every release of RCtool and is also available from the home page of RCtool40

 The Pro mode can be activated via the Help menu ‘Help -> Set Pro Mode -> On’.41
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Resolving conflicts from redundancies (duplicates)
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .42

 RCtool tries automatically during all import processes  to avoid redundan43 -
cies, i.e. to avoid importing redundant data that are already present in the data base. 
However, it may well be that not all redundancies can be removed during an import 
process. This is typically the case when your RCtool data base contained already re-
dundancies before you made the import. Redundancies can also be generated through 
other actions, e.g. you duplicate an  Author Response or a RE Annotation, perhaps ac-
cidentally or intentionally during an edit. However, redundant data may cause problems, 
notably by disrupting the relationship between Review Comments and Author Respons-
es and/or RE Annotations, respectively. Thus you should always try to avoid redundan-
cies and remove duplicates from your data base. In a data base such as RCtool redun-
dancies are present in form of so-called duplicate records, i.e. records of the same in-
formation content. E.g. two Author Responses or three RE Annotations of identical con-
tent.

You can anytime check the presence of such redundancies by using in the Pro mode  44

one of the following menu commands from submenu ‘Pro -> Scripts -> Resolve 
conflicts’:

• ‘Find duplicate Review Comments’
• ‘Find duplicate Author Responses’
• ‘Find duplicate RE Annotations’

It is easy to remove duplicates: You can conveniently clean-out your data base any time 
from duplicates by using following menu commands from aforementioned submenu: 

• ‘Clean-out duplicate Review Comments’
• ‘Clean-out duplicate Author Responses’
• ‘Clean-out duplicate RE Annotations’

Note, these commands operate only on the currently selected set of records. 

 This file comes with every release of RCtool and is also available from the home page of RCtool42

 Such import processes are described in this guide in sections «Collaboration», notably subsection «Im43 -
port a colleague’s work into the master data base», «Restoring your RCtool data base», «Importing data 
from another RCtool data base», plus from ‘RCtool Read Me.pdf’ sections «Importing Review Comments» 
and «Updating RCtool»

 Pro mode can anytime be activated by choosing menu command ‘Help -> Set Pro Mode -> On’.44
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If there are multiple duplicates present, it may well be that a single clean-out command 
may not suffice. Repeatedly execute the clean-out command until you have all du-
plicates removed. 

In rare cases it may well be that you fail to clean-out all duplicates. This happens when-
ever the duplicates are actually not true duplicates. There is an implementation restric-
tion in RCtool – due to a limitation of FileMaker – that causes duplicates to be reported 
while they are actually not true duplicates. This is the case when longer Author Re-
sponses or RE Annotations are identical in the beginning  and start to differ only to45 -
wards their later parts. RCtool is programmed such that no such alleged duplicates are 
deleted, yet for efficiency reasons it is unavoidable that they are reported as duplicates 
nevertheless.

 In some even rarer cases RCtool may report duplicate primary keys. You should 
never work with a RCtool data base in such a state and should always try to fix the 
issue. Otherwise you risk to disrupt the relationship between Review Comments and Au-
thor Responses and/or RE Annotations, respectively. Such an issue is not the fault of 
RCtool and RCtool cannot fix it. The fault is here with the input data that contain the 
same comment number for actually differing comments, something which must not oc-
cur. 

Use the menu command ‘Search for problems in data base’ to test for the presence of 
any kind of problems in your data base. This command can detect additional inconsis-
tencies such as conflicts in the primary keys of Review Comments, Author Responses, 
and/or RE Annotations or essential fields being empty. If this command finds no records, 
your RCtool data base is technically in excellent shape. 

Otherwise heed these recommendations: 

• In a first step you can execute menu command ‘Pro -> Scripts -> Resolve conflicts 
-> Fix current sets of Author Responses and RE Annotations‘. This will fix empty 
critical fields in Author Responses and RE Annotations and assign proper values to 
those. If no such problems are actually present RCtool cannot fix, this command is 
without effect.

• Duplicates in Review Comments need always be fixed and should never be 
tolerated. Fix those by deleting the faulty set of Review Comments. The easiest 
approach here is to reimport proper data by replacing the existing Review Com-
ments during the import. 

• Duplicates in Author Responses or RE Annotations need not be cleaned-out im-
mediately. Yet, it is recommended to clean them out as soon as possible. Other-
wise you will get histories, which are actually not true histories (see also section 
«Managing histories»). Exceptions: Long multiple Author Responses or RE Anno-

 A maximum of 100 characters is used for duplicate detection, while not only the fields ‘Author_Re45 -
sponse’ or ‘Notes’ for REs matter but also other fields are using up some of these 100 characters. The 
actual amount differs e.g. with the length of the comment number and that of other critical fields. 
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tations on the same Review Comment that are first identical and begin to differ 
only towards their end are to be tolerated, despite RCtool reporting them as dupli-
cates.32 Since they are not really identical they are elements of a true history. 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Analysing Comments
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .46

Comments can be analysed statistically in two ways:

a) Number of Review Comments every page of the draft received (page statistics)
b) Number of Review Comments a reviewer provided (reviewer statistics)

In both cases perform following steps:

1) Choose menu command ‘Analysis -> Reset all statistics’ to prepare for the analysis 
including clearing of possibly present old results that might otherwise distort the 
results

2) Choose menu command ‘Analysis -> Compute statistics’ to run the analysis routine
3) select which results you wish to view and possibly export

Step 3) is done by either optionally visiting the results with one of the two ‘Show …’ 
menus or then by immediately exporting the statistics of interest. It is recommended to 
export the results of the analysis to a text file. That file can then be opened by Excel or 
perhaps best by a R-script for generating a histogram. See the RCtool web site for such 
a R-script.

The following graph was generated using above commands to compute and export the 
number of comments every page of the SR1.5 FOD of chapter 1 has received:

 This file comes with every release of RCtool and is also available from the home page of RCtool46
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Finding comments via clipboard
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .47

RCtool offers a very nifty feature, which is to find comments via a list of numbers. Say 
you took notes of critical comments that are related and address a particular topic, say 
on the Structured Expert Dialogue as it relates to the Paris Agreement, yet would not be 
easy to find via a common keyword. That list may look similar to this 

32066, 36394, 43996, 27952, 52750, 46460 (6) 
 
RCtool supports you in immediately refinding those comments by simply copying them 
to the clipboard and choose menu command ‘Comments -> Find comments -> Find by 
clipboard list (comma separated)’: 
 

And the listed comments are immediately selected. I use this command so often I have 
assigned it a keyboard shortcut (Ctrl^0 on the Mac). RCtool offers of course also a com-
panion command ‘Comments -> Find comments -> Copy current comments # into clip-
baord’, which creates in the clipboard a list as shown above from the currently selected 
comments, a text which can be easily pasted into your notes. Again I need a keyboard 
shortcut (Ctrl^9 on the Mac) for that, using as RE this command all the time. Additional 
commands in that group offer even more flexibility during reading of comments. 

 This file comes with every release of RCtool and is also available from the home page of RCtool47
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Using shortcuts
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .48

RCtool has been designed to support the power user. This means common functions 
are also offered as a menu command, some of them only in the Pro menus. On the 
Macintosh platform this allows to install conveniently keyboard shortcuts in addition to 
the default ones provided by FileMaker. E.g. I use following shortcuts for frequently used 
menu commands from the Pro submenu ‘Helpers’. 
 

  
Above shortcuts support greatly the work as a review editor on a set of critical com-
ments as resulting from e.g. ‘Comments -> Find comments -> Find critical comments…’ 
by setting priorities, Ctrl^V for «Set priority ‘very high’», Ctrl^H for «Set priority ‘high’» 
etc. Note, depending on the phase you are currently working different sets of shortcuts 
may be helpful to work efficiently. 

 This file comes with every release of RCtool and is also available from the home page of RCtool48
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Archiving RCtool data
The following assumes you have installed the RCtool software and made ready as described in 
the installation tutorial of the file ‘ RCtool Read Me.pdf’ .49

All archiving is done to tab separated text files for long term storage of the data inde-
pendent of any software. The encoding is done with UTF-8 and the files contain at the 
top a header row describing the content of the column below. An archive consists of 
several files, one for each data type contained in the RCtool data base. The files are au-
tomatically created and named and stored in the same pre-installed folder as backups, 
i.e. subfolder ‘RCtool data archives’ in the RCtool work folder.50

A RCtool data base can be fully restored from an archive. 

The following menu commands serve this purpose: 
 

 This file comes with every release of RCtool and is also available from the home page of RCtool49

 See ‘ RCtool Read Me.pdf’ for details50
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In this guide not all figures are already updated to reflect the renaming from REtool to 
RCtool
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