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REtool 1.8.2
This is the release of REtool version 1.8.2. REtool is a manager for IPCC  review com-
ments, designed for use in the 6th assessment cycle. REtool is targeted first of all at 
Review Editors, but may also be of interest for other users, such as TSU staff, chapter 
scientists, CLAs and LAs, e.g. when responding to review comments.

Find more on REtool also at its home page:   http://se-server.ethz.ch/REtool/

What you need

REtool is available for free. It was developed using FileMaker Pro 14 Advanced 
(v14.0.6), yet, in its standard version, REtool can be used independently from FileMaker 
Pro Advanced (find deta i ls on th is l icense in the nearby fi le ‘FMP 
Acknowledgements.pdf’). In its standard version REtool cannot be modified. Thus RE-
tool is also released for FileMaker Pro Advanced (v14 or later), so that anyone who is in 
possession of such a license, can not only  use REtool but also modify it. We recom-
mend to get in touch with the developers first if you plan to modify REtool.

In addition to REtool itself you also need a PDF reader to make good use of REtool. 
Under Windows we recommend to use Adobe Acrobat Reader DC (default setting in this 
release) or Adobe Acrobat Pro DC. On the Macintosh we recommend the powerful open 
source pdf reader Skim (default setting in this release). Unfortunately the functionality of 
‘Adobe Reader’ on the Macintosh is limited. Therefore, it is recommended to work with a 
better PDF reader such as Skim or then Adobe Acrobat. 

First Time Installation

The core of REtool consists of three files:

! ‘REtool‘!! ! the REtool application
! ‘REtool-main’!! (extension ‘.fmpur’) storing the review comments
! ‘REtool-textlinks’! (extension ‘.fmpur’) storing meta data to link comments with PDFs

  To install REtool anew on your system simply copy the REtool folder as released 
to your disk into a working folder of your choice. Please start from the provided sub-
folder structure and do not change it (unless you know well what you are doing). Use for 

For a quick start, focus on bold text in 
the paragraphs marked with a green circle:    
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each report a different copy of the REtool folder should you work with more than one 
IPCC report. The REtool working folder looks similar to this on the Macintosh:

The red rectangle encloses the main files consisting of the REtool application (here hav-
ing a bluish icon) and the two data base files ‘REtool-main.fmpur’ and ‘REtool-
textlinks.fmpur’. 

The green rectangle encloses the so-called REtool work folders, to receive the draft 
specific files for the Zero Order Draft (ZOD), the First Order Draft (FOD), the Second 
Order Draft (SOD), and the Final Government Draft (FGD).

The blue rectangle encloses the so-called TAT-textlinks files. They are to contain the 
meta data on the structure of each draft and are ready to receive those meta data in 
form of a spreadsheet for each product of the IPCC 6th assessment cycle.

Under Windows the same principle of organizing the data applies as shown above, but 
there are many  more files. First, it is recommended to unpack the downloaded zip on 
your Desktop. After unpacking the zip folder you need to locate the actual REtool appli-
cation within the unpacked folder. It resides within a subfolder named ‘REtool’ within 
which all files needed are actually stored. The main files (red rectangle) within your RE-
tool folder should look similar to the following: 
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Double-click the application RETool.exe. If you are invited to install REtool do so by in-
stalling REtool at a final destination, which is best chosen within your Documents folder. 
If asked, create an icon on your desktop and allow for an entry in your startup menu. If 
REtool was installed at such a final destination different from your desktop, use only  that 
one and discard the original unpacked folder together with the downloaded zip file.

  It is recommended to always first  open the REtool application, e.g. by  a double-
click onto the application’s icon. Never try to open the data base file ‘REtool-main’ (with 
extension ‘.fmpur’). Note, opening REtool will always open also its related data base file, 
i.e. ‘REtool-main’, the main file you work in.

Upon launching an REtool never used before you are asked the question whether you 
use REtool for the first time or whether you have used it before and an older version of 
REtool has been backed up or exists otherwise on your system:

Let us assume it is your first use. Click that button. You should then make two settings 
right away: Tell REtool your initials and choose your IPCC report:

1.   Tell REtool your initials and your role. Under Windows you are asked for your 
name right away when you launch REtool for the first time. If you missed that oppor-
tunity or wish to check once more what you then entered choose menu command 
‘Edit -> Preferences...’ and do the same as described below for the Macintosh. On 
the Macintosh always choose the menu command ‘REtool -> Edit -> Preferences...’. 
A dialog similar to the following opens
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Click radio-button ‘Other’ and enter your initials (mine’s being ‘AF’). You can enter 
here whatever you want, but for brevity reasons I recommend to enter only initials, 
not an entire name, but of course initials that tell you apart from your colleagues. 
This needs to be done only once.

Secondly you are asked about your role:

               

Let’s assume you are a review editor and you then enter RE. If you are neither a RE 
nor an Author, e.g. TSU staff, enter Other.

2.   Tell REtool which IPCC report. In the top left corner of the REtool window you 
see a pop-up menu now showing the current mode, i.e. ‘Edit Mode: Standard’:
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This pop-up menu is important for you. It lets you control the so-called “modes” of 
REtool. Let’s switch to another mode by clicking onto the current mode ‘Edit Mode: 
Standard’ and choosing in the shown pop-up menu the new mode you intend to go. 
Here we choose ‘REtool Settings’:

                                 
                        
The chosen mode ‘REtool Settings‘ gives you an entirely new view to REtool: It al-
lows you to specify several critical settings. For the time being there is only one set-
ting to make, a setting which is of fundamental importance: Choosing your IPCC 
report. You find in the top right corner the factory set report, i.e. SR1.5 (left part in 
figure below). Behind ‘SR1.5’ is actually just another popup menu.
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Click on ‘SR1.5‘ and the pop-up menu shows, with the current report being checked 
(middle part in above figure). To change to another report, say ‘SROCC‘, simply 
choose that report. The top right corner and the window title should then have 
changed to the new report, say ‘SROCC’ (right part in above figure). From now on 
REtool knows with which report you are working. Again, this needs to be done only 
once.2 

Since we assume here that you are a RE, you will also be asked about your chapter 
for more convenient use of REtool:

                 

Once you told REtool all this, you are ready to go. You need not repeat above set-
tings when you merely update. In such a case it is recommended to click on that but-
ton instead of ‘First use’ and automatically retrieve all those data from the last ver-
sion of the data base you used.

This completes the first installation and best go back to ‘Edit Mode: Standard’.

Give REtool the data: For REtool to meaningfully work, you need to import data. All 
needed data are provided by first populating the REtool work folders (green rectangle in 
first figure) with files and then secondly import those data into REtool by executing a 
dedicated menu command from within REtool. The needed files are provided in a draft 
specific manner and that is why you have for each draft a subfolder and within that 
folder for every category of data again a dedicated subfolder. This is illustrated in the 
graph below for the First Order Draft (FOD), the REtool work folder ‘2-FOD’. That folder 
is structured by containing following subfolders:
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For each category of data, i.e. PDFs of the draft texts, Review Comments, Author Re-
sponses, RE Annotations, plus exported REtool Core Data exists a dedicated subfolder. 
Please populate now these subfolders with files so that REtool can use them. It is rec-
ommended to stick to the given folder structure and not to change any folder names. 
You can add your own subfolders or files, but please keep  the provided folders un-
changed.

 Importing Review Comments: Upon first launch, the data base of REtool as re-
leased is empty and contains no review comments and also no meta data. The reason 
is that those data are confidential and can’t be distributed with the freely available RE-
tool. To get the review comments of a particular draft you need to perform following 
two steps:

1. Populate the respective work folder (green rectangle), i.e. for Review Comments the 
subfolder named ‘z1-Review Comments’ with the spreadsheets containing the 
review comments. You need to do that for every draft you work with. Do not change 
the names of those files. Simply move or copy the files as received from TSU or 
downloaded from the Data Management System (DMS). Below the folder as it looks 
once you have populated it with all review comment files for the FOD of SROCC:
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You see there files for each chapter, the Cross Chapter Box 5 and the review com-
ments pertaining to the entire report. 

2. Import the wanted data, say for chapter 2 into REtool. To this end choose from 
within REtool the menu command ‘Import Review Comments from spread-
sheet...‘

               

and follow the instructions, i.e. specify you want the data for the FOD and chapter 2. 
If all goes well you should have now all 1447 Review Comments on chapter 2 of the 
SROCC FOD in REtool and the REtool window should look similar to this

      

You are now ready to work already with those comments. Read them, enter Author 
Responses or as Review Editor (RE) annotate the comments and/or the Author Re-
sponses (if already available). You can search in every section of the comments etc. 
etc. Submenu ‘Comments -> Find comments’ provides many commands for quickly 
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finding specific comments. Please consult the guide to learn more about the many 
features of REtool.

Typically you do a second import, i.e. you import also the comments for the entire 
report. When you are asked for the chapter enter the abbreviation ALL. You can of 
course do imports for other chapters or other categories of data as supported by 
REtool.3 Please note in this context the following is important to remember always: You 
should import the review comments only  once. Note also, REtool lets you freely  import 
review comments in whichever order and as many times you wish. On the other hand, to 
work well, REtool should contain every review comment only  once or things may get 
messy. REtool warns you, should you encounter such a state where the same comment 
is present more than once, so-called duplicates. Advanced techniques4 let you fix such a 
state. Yet, if you stick to the rule to import the same Review Comments only  once (or 
replace the existing ones), everything should work smoothly. 

Note also,  the more comments you store at a time, the slower some processing may 
become. For REs it is therefore recommended to store only the comments pertaining to 
the chapter for which you are RE and accumulate the comments only as drafts become 
available.

Note, importing data into REtool is in general quite safe, since REtool makes automati-
cally by default always first a backup  from your data base. This happens just before it 
imports new data (those backups reside in the subfolder ‘REtool data archives’). In case 
anything goes wrong, It is highly recommended to quit right away REtool and to discard 
the current copy of ‘REtool-main’. Then move a copy of the just backed up file to the 
working location and rename it by taking out the automatically  appended date and time 
information from the file name. Make sure the name of the thus restored data base file is 
‘REtool-main.fmpur’. Open application REtool once more and you should have resumed 
exactly where you were before the import. 5
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3 Currently TSUs change the structure of comments spreadsheets all the time. Unfortunately this may re-
sult in REtool to fail to import the data correctly. E.g. REtool may refuse to import any data or some data 
end up in the wrong place, e.g. reviewer’s name ends up as comments etc. If you encounter difficulties in 
importing review comments REtool offers a Pro Mode (Help -> Set Pro Mode -> On) you can resort to 
more advanced commands or contact the developer (see the home page of REtool) and ask for a new 
version (if that is the case please provide also the spreadsheet you tried to import). Otherwise, should you 
own a license for a compatible FileMaker Pro Advanced (v14.0.6 or later), you can easily adjust the import 
command for the actual spreadsheet structure yourself (again the developer is happy to help).

4 Available in the Pro Mode (Help -> Set Pro Mode -> On) under submenu ‘Scripts -> Resolve Conflicts

5 There are several other techniques to accomplish the same. E.g. menu command ‘File -> Backup and 
Updating -> Restore data from backup or previous version (update)...’ can help to restore a previous state 
of REtool. In general your data are generally safe and REtool is very flexible in importing and exporting 
data.
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Jumping to PDFs: A strength of REtool is to be able to jump to a draft text location as 
referenced by a review comment. Similarly REtool can jump to the draft text by an ele-
ment in the ‘Table of Contents’ (TOC) view of REtool. First, provide the PDFs as de-
scribed next.

 Provide the PDFs: Move or copy the PDFs of the draft texts you are working with to 
the draft dedicated subfolder ‘pdfs’ in the REtool working folders (green rectangle). 
Again let us do this for the SROCC. Simply store the PDFs of the ZOD in subfolder ‘1-
ZOD/pdfs’ and those of the FOD in subfolder ‘2-FOD/pdfs’. The dedicated subfolder 
‘pdfs’ may then look similar to this (left):

Now, REtool by default can’t work with the PDF names shown to the left because they 
are named in a non-standard manner (and it may also well be your files are actually 
named very differently than those shown above). Simply rename the PDFs so that they 
can be recognized by REtool. The rule is that chapter PDFs should be named ‘Chapter 
1.pdf’, ‘Chapter 2.pdf’, ‘Chapter 3.pdf’ etc.6 7  The cross chapter box is named as CCB5. 
After renaming the pdfs, the folder should look similar to the one shown on the right 
above.

Settings for the PDF Reader: Finally you need also to check whether the pdf reader on 
your system you intend to use is made known to REtool. To this end visit mode ‘REtool 
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6 In addition to chapters further reserved names are: SPM, TS, CCP1 .. CCP10 plus CCB, CCB1 .. CCB5.

7 Hint for the advanced: On the Macintosh you can also use the Unix symbolic links with the proper name, 
i.e. instead of the provided folder ‘pdfs’ having a symbolic link with the identical name, but that points to 
whatever folder where you store the PDFs. Symbolic links work also for individual PDFs. You can also 
change the names of those subfolders, given you do at the same time modify the settings in REtool ac-
cordingly (read on). In general make sure you have consistent settings as shown in mode ‘REtool Set-
tings’ and the actual subfolders and PDF names you are using. Visit mode ‘REtool Settings’ (pop-up menu 
next to the word ‘Mode’ in the top left corner of the window) and make sure the strings in section «Loca-
tion of draft PDFs» match accurately the folder names you are actually using on your system.



Settings’ (pop-up menu next to the word ‘Mode’ in the top  left corner of the window) and 
choose the appropriate settings on the top  of the page in section «Settings for accessing 
PDFs of draft documents». 

Now, you should already be able to jump from a comment to the referenced text in the 
PDF.8  Use the dark buttons in the top right corner of every comment:

Above example is not that exciting, since the comment pertains to the whole chapter 
and you jump then only to the first page of that chapter. Jumping is most helpful if you 
want to go to particular sections within the draft. Scroll down to another comment refer-
encing a particular paragraph or figure and try it out. Clicking on the same button should 
immediately bring you to the referenced section in the PDF.

REtool can also jump from a table of contents view to corresponding pages in the PDFs. 
Switch to the mode ‘Table of contents’ by using the pop-up  menu in the top left corner, 
i.e. leave the mode ‘Edit Mode: Standard’ and go to the mode ‘Table of contents’. This is 
simply another view (in FM jargon called a layout) to your data in your data base. Here 
you see no review comments. Instead you can see here a table of contents of the report 
you work with and jump  from every listed item to the corresponding location in the PDF. 
However, because of first use, data are missing and the table of content is empty. 

12/27

8 Under Windows you need to launch the PDF Reader first manually. Once open, the jumping to PDF’s 
should work.



To get the table of contents populated, you need first to import the needed meta data 
into the data base file

! ‘REtool-textlinks’! (extension ‘.fmpur’)

Note, the purpose of ‘REtool-textlinks’ is to store the necessary meta-data on the draft 
structure. This enables the jumping to referenced texts, figures, footnotes, tables, FAQs 
etc. in the PDF via the Table of contents view.9 Open the auxiliary file ‘REtool-textlinks‘ 
by clicking on the button in the middle of the toolbar at the top of the window labelled 
‘Open REtool-textlinks’. 

Note, the needed meta data are of course report and draft specific. They typically need 
to be updated as each draft becomes available. The meta data are available in form of 
spreadsheets. Again you should be able to get those from the same sources you have 
obtained the review comments.10

 Import the needed meta data in ‘REtool-textlinks’: As released, file ‘REtool-
textlinks’ is empty and contains no meta data. To obtain the needed data, switch to 
mode ‘Table of contents’ (pop-up menu next to Mode in top  left corner) and click on the 
button ‘OpenREtool-textlinks‘. Note, this is something you do typically only rarely, since 
the window for the file ‘REtool-textlinks’ is normally closed and accessed by ‘REtool-
main’ in a hidden manner behind the scene only. 

Similarly as with Review Comments you need to populate the dedicated folders in the 
REtool work folder, the TAT-textlinks subfolders (blue rectangle in first figure) with the 
spreadsheet files that contain the meta data.  Make sure that for each draft and all 
chapters you wish to work with you have all the corresponding files available. As of this 
writing the SROCC has advanced to the FOD. Meta data available so far are for the 
ZOD and the FOD. Perform these two steps:

1. Move (or copy) following two files to the SROCC subfolder within the ‘0-TAT-textlinks 
‘folder (blue rectangle in first figure):
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9 Note, the use of the Table of contents view is optional. The jumping to a location in the PDF of a draft as 
referenced by a comment and described above works also without the textlinks. However, certain features 
in the standard view are also affected by the absence of textlinks. E.g. finding comments by section 
(menu command ‘Comments ->  Find comments -> Find comments for a section/section range...’) re-
quires also the presence of the textlinks. Similarly the pop-up display of the title of a section when hover-
ing with the cursor over the top right corner field requires also the presence of textlinks.

10 Those spreadsheets are outputs from TAT (Text Analysis Tools). TAT is released separately from RE-
tool.



                          
              
Your TAT-textlinks subfolder for SROCC should then look similar to above. Best keep 
those files present all the time and add more files as more drafts, e.g. the SOD and 
FGD meta data files describing their content, become available.11 

2. Import for the ZOD and the FOD the meta data into ‘REtool-textlinks’ by choos-
ing menu command ‘Scripts -> Import TOC from spreadsheet...’, select the 
wanted spreadsheet once for the ZOD and then for the FOD by appending the FOD 
to the data base.12

 If all looks fine, close the window.

This needs to be done only once and such a step  is to be repeated only as the SOD be-
comes available. Should you accidentally  try to import the same data a second time, fol-
lowing alert appears:
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11 Note, while working with several reports requires to have another copy of REtool, the TAT-textlinks 
folder is the only thing that can be shared among reports and remains always the same. Above shown 
folder structure supports all products of the IPCC 6th assessment cycle.

12 If something goes wrong, simply start all over by replacing the data.



Note, the import mode Replace replaces whatever data are already  present in ‘REtool-
textlinks’ for the draft. In this case you are actually safe to replace the existing data to 
avoid having the entire meta data twice in the data base. Such a state is always to be 
avoided.13

Once the meta data are imported, the Table of Contents should now be available to you. 
It should look similar to this (here illustrated for the SR1.5):

The pop-up menus on the top allow you to focus on report elements such as chapter 
sections by level in the hierarchy, or only on figures, tables, boxes, footnotes, FAQs etc. 
Each element listed (e.g. in above figure ‘ES 1   Executive Summary (Chapter 1)’) is 
also a button allowing you to jump  right away to the referenced PDF section/page. This 
can be particularly handy e.g. for TSU staff or anyone else analyzing an entire report.

There is an important side effect of having the meta data of a report available. This al-
lows you to also use the second button in the top  right corner of each comment to its 
max. By default this button shows SOD when you work with the FOD. 
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13 The mode Append allows to accumulate data. Use it when you import partial data, e.g. during importing 
of Review Comments, one chapter after the other. The mode Replace is only recommended whenever 
you wish to start from scratch. In the case of textlinks, where you normally import from a single file the 
meta data of the entire draft, the mode Append makes little sense.



Is this button useless until the SOD becomes available? No. When you are working with 
the FOD, you typically also have the ZOD available. Above you just imported the meta 
data also of the ZOD. You can now use those just imported meta data to compare the 
FOD with the ZOD. Simply switch to looking backwards for comparisons. Go to mode 
‘REtool Settings’ (top left corner pop-up  menu) and change the ‘Comparison mode’ from 
forward to backward:

Back to ‘Edit Mode: Standard’ (top left corner pop-up  menu) the second dark button in 
the top right corner of every Review Comment shows now ZOD and no longer SOD: 

Thanks to the meta data on the ZOD just imported, that button is now fully empowered14 
and can jump to the corresponding section or other draft element in the ZOD. Say  you 
look at a comment on Figure 2.5. Thanks to these buttons labelled FOD and ZOD you 
can now jump to Figure 2.5 in both the FOD as well as the ZOD. REtool knows where 
the two Figures 2.5 are and helps you to compare the two drafts next to each other. 
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14 Without the meta data the button merely jumps to the same page in the ZOD as referenced in the FOD



The guide15 contains at the begin a figure that gives you an overview of those relation-
ships. REtool can at any time compare two drafts, either in the forward or backward 
looking mode and hereby compare every draft with every other draft.

In REtool-textlinks installed meta data does also support the pop-up  display of section 
titles and other explicit information about the element currently shown in the top right 
corner. Here the example of a text reference starting at page 2, line 96 and ending at 
page 2, line 103. That text belongs to section 1.2.1 and the title of that section becomes 
visible in the yellow pop-up  menu when hovering over the field where the cursor is 
shown:

Finally, there are also a few menu commands such as ‘Comments -> Find comments -> 
Find comments for a section/section range...’. To really work this command requires also 
that the TOC meta data are installed in REtool-textlinks. 

The installation of the meta data in REtool-textlinks is in general optional. Aside from the 
features described above the core functions of REtool work already well without having 
the meta data installed.

 To check the entire installation scroll to any review comment and click on the but-
tons in the top right corner of the comment. Under Windows you may need first to 
launch the PDF reader yourself. Normally any click on any of the two dark buttons in the 
top right corner should open the PDF at the wanted page. This should also be the case 
in the mode ‘Table of contents’ (use top  left corner pop-up menu). Clicking on a listed 
section, figure, or table should open the PDF at that section, figure, or table etc.

This completes the basic installation of REtool.

Please consult the guide to learn about the actual use of REtool. Note, there is a menu 
command available to open the guide: ‘Help  -> REtool User Guide’. Additionally you can 
also visit the web page of REtool using the menu command ‘Help  -> Visit REtool web 
page’. That web page offers this Read Me, the guide, and FAQs. The latter I plan to up-
date as I receive feedback from you. You find there also under section ‘Home & Down-
loads -> Links’ a link to send me an e-mail.
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as well as from within REtool (menu ‘Help -> Open REtool User Guide’)
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Updating REtool

 Updating your installation of REtool with a new version consists of following 
three steps: (i) Backup, (ii) replace old with the new files contained in the update, 
(iii) restore the data from the backup.

1. Make a backup of your current REtool data base by using the menu command 
‘File -> Backup and Updating -> Backup data base REtool (main, textlinks)’:

Note, a full backup of both files ‘REtool-main’ and ‘REtool-textlinks’ (both typically 
with the extension ‘fmpur’) are then created with a date and time stamp appended to 
the file name. Those backup files are always stored in the subfolder ‘REtool data ar-
chives‘. That folder came with the first time REtool release. Having made a backup 
that folder may look similar to this 16

        

2. Move or copy any file that came with the update to the REtool folder by re-
placement. REtool functions only correctly if file names are not changed. Thus it is 
important to replace any old file having the same name with the new one. You have 
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16 Note, that same folder stores also all backups you may have created automatically, e.g. just before hav-
ing imported some data (unless you should have unchecked the preference ‘Always backup’).



made a backup in the first step, thus there is no risk of data loss. The replacement 
needs always to be done for REtool-main where you replace the existing file with 
the new one.17 The new file contains the new version of the REtool data base and 
note, no new REtool application is needed for an update. But that new REtool-main 
file is empty, i.e. it contains no data, no Review Comments, no Author Responses, 
and no RE Annotations. Therefore you need to perform also the next step to com-
plete the update.

If your update contains also a new REtool-textlinks file, replace that one as well. 
Remember, step 1 has already made a backup of the data that were stored in the old 
REtool-textlinks.

If your update contains also a new REtool_User_Guide file, simply add the new 
REtool_User_Guide to the folder. To avoid confusion, I recommend to delete at this 
point the old user guide.18

3. The new REtool data base is empty, it contains no data, only a new functionality. To 
restore the data simply launch the application REtool. Since it is empty, it will ask 
you following question:

            

Clicking on button ‘Updating’ launches a full restore process. Please follow the in-
structions. This process restores all data from the backup files you select. E.g. in 
step 1 you created the backup file you now select to restore from during the update
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17 In rarer cases the file ‘REtool-textlinks’ may also need to be replaced (see below)

18 The only exception to this would be when you have invested in the old guide by annotating the PDF.



Note, this restores not only the data from REtool-main, i.e. Review Comments, 
Author Responses, RE Annotations, and REtool settings, but also the data from 
REtool-textlinks, the Table of Contents (TOC) meta data allowing you to link data on 
the structure of the draft with all other REtool data. 

Alternatively, you can also click ‘First use’ despite updating and nothing is lost. You can 
execute the data restore yourself by using menu command ‘File -> Backup and Updat-
ing -> Restore main data from backup or previous version (update)...‘ 

The restoring should succeed and as a result all your data as previously stored within 
file ‘REtool-main’ should now be present again in the new version of your REtool data 
base. Note, this includes all REtool settings, including old preferences that may deviate 
from default, so-called factory settings. You can overwrite your settings anytime by click-
ing on the button ‘Factory Reset’ in mode ‘REtool Settings’ to resume an initial factory 
state of all settings. IMPORTANT: Note, this may require to choose your report and pre-
ferred chapter once again.

At the end of updating you get a summary of what was restored similar to this:

           

This means there are 11,031 Review Comments, 6,981 Author Responses, and 1,190 
RE Annotations in total present in your data base, given as a number triple delimited by 
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a vertical bar (‘|’). The sum of these, the so-called 19,202 records is given in the paren-
theses behind each triple. Below you get how these records distribute for all four drafts, 
a triple for the ZOD, FOD, SOD, and FGD each, again each time followed by a record 
total in parentheses. The legend at the bottom is a reminder how to read the sequence 
of numbers for each number triple. Given you started from an empty data base, this 
means all those 19,202 records were restored from the backup. The old data can now 
be used exactly as they were in the new REtool offering a new functionality.

In case you have replaced in step 2 also REtool-textlinks, that file is also empty, i.e. it 
contains no data. To restore its data use menu command ‘File -> Backup and Updating 
-> Restore textlinks data from backup or previous version (update)...’: 

In some cases, e.g. at the stage of the ZOD or FOD, it may be even easier to quickly 
reimport all the meta data you work with from the spreadsheets by using the same 
commands as you used during the first installation for each draft you work with. To this 
end you need first to open the file ‘REtool-textlinks’ by switching to mode ‘Table of con-
tents’.

                                          

There open the auxiliary file ‘REtool-textlinks‘ by clicking on the button in the middle of 
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the toolbar at the top of the window labelled ‘Open REtool-textlinks’:

                     

Then choose menu command ‘Scripts -> Import TOC from spreadsheet...’

That should suffice and all meta data should be available again, similar what you would 
obtain when restoring from a previously backed up file. However note, you must not 
simply duplicate the backup file ‘REtool-textlinks--backup-xyz.fmpur’ and rename it to 
‘REtool-textlinks.fmpur’. Albeit the data stored in the data base have not changed, the 
data base’s functionality may well have changed from the previous version. Understand 
that the restore transfers only the data, but not the functionality of the REtool data base, 
which can never be transferred.
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Additional and optional installation steps 

Finally  to use the new archiving feature fully, a little shell script needs to be made 
available to REtool on the Macintosh. It is best copied/moved once to the ~/bin folder 
(create this folder in your home folder, if it does not exist yet on your Macintosh). This 
shell script ‘fixTABdelimFMExportForUTF8.sh’ (chmod 775 or 777) is executed only 
when you archive some data from REtool to a text archive, not when exporting to Excel 
files. Thus its need is likely to be rare. Aforementioned shell script is installed once only 
and needs not be reinstalled with every update of REtool. If you use REtool on a Macin-
tosh it is recommended to install this shell script.

Text Analysis Tools (TAT): Meta data as needed to jump to PDFs can be generated 
from the PDFs themselves. This is the purpose of the Text Analysis Tools (TAT) that are 
also available from the same location as REtool. The installation of TAT19 is optional and 
REtool works also fully without it. TAT serves only to extract the meta data from a draft, 
making hereby the core of REtools (REtool-textlinks and REtool-main) fully  functional. 
Thus TAT is needed whenever the spreadsheet with meta data for ‘REtool-textlinks’ is 
missing and/or not yet available. TAT and REtool can be used independently, thanks to 
the technique to exchange meta data only  in form of a spreadsheet: TAT produces the 
spreadsheet, ‘REtool-textlinks’ imports it. Yet, TAT’s functionality  is of course essential 
for REtool to link a draft’s PDFs to REtool and hereby enhances REtools’ usability 
greatly. Note, TAT comes with its own Read Me file.
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19 TAT consists of two elements: A Unix (LInux, OS X) dependent processor for the initial text files using 
standard shell scripts making good use of the powerful Unix tool awk and a FileMaker based post proces-
sor to generate the spreadsheets that go into the TAT-textlink subfolders (blue rectangle in first figure).



Using REtool

The help file 

! REtool_User_Guide-1.8.2.pdf

explains the basic use of REtool. The application REtool offers also a menu command 
to open that help file in the REtool help menu (‘Help -> REtool User Guide’).20 

af, 9.Dec.2018
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Version history

• 1.8.2! Version 1.8.2 contains following improvements
• New menu commands for author histories that show comments with or 

without the flag ‘Author Response finalized’
• New and more logically arranged menu commands in Pro submenu 

‘Import data’ for greater convenience 
• New menu commands that are useful when discarding a just made 

import that turned out to be bad in Pro submenu ‘Resolve conflicts’
• Pro menu ‘Pro -> Scripts -> Resolve conflicts -> Search for problems 

in REtool data base’ detects and reports now also on orphaned Author 
Responses and/or RE Annotations as may result from incomplete im-
ports when using an ‘... import from any ...’ command

• The guide has been significantly extended once more by sections 
«Importing data via Pro mode» and «Check internal consistency of 
your REtool data base».

! and in addition following bug fixes:
• Restoring of Author Responses and RE Annotations from a spread-

sheet
• For review stage ALL the commands from submenu ‘Comments -> 

Show comments’ fixed

• 1.8.1! Version 1.8.1 is very similar to 1.8. These are the changes:

• Importing spreadsheets from collaboration into the quarantine can now 
also be selected with the standard file selection dialogs and the drag 
and drop technique is deprecated.

• The guide has been updated accordingly.
• Minor improvements and a few bug fixes.

• 1.8! Version 1.8 is similar to 1.8fc12 to fully implement the design for the entire 
AR6 cycle till the SYR. It brings more user friendliness and stability includ-
ing following:

• New user interface under Windows for restoring and updating. The 
implementation for Windows is now at par with and identical with the 
behavior offered on the Mac.

• Polished and detailed informing of the user during importing, restoring, 
or updating

• Elements of the user interface offer now pop-up help texts when hov-
ering over them
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• Fully consistent handling of duplicates during all imports and com-
mands to otherwise resolve possible inconsistencies in a REtool data 
base

• Numerous bug fixes including the opening of the guide via the Help 
menu

• Further enhancements of the guide by new sections such as «Analys-
ing Comments» and a more detailed description of the handling of re-
dundant duplicates and other more technical data base issues

• 1.8fc12! Version 1.8fc12 represents a major step towards fully implementing the de-
sign of REtool for the entire AR6 cycle till the SYR. This includes following:

• Extending the support for latest Author Responses for SROCC and 
SRCCL. 

• Major revision of sharing data (exporting, importing). This includes an 
effort to standardize the format of the spreadsheets used for sharing 
data. 

• New simplified menu structure reflecting the latter philosophy. 
• Full and orthogonal support for authors and REs. 
• Many improvements and substantive enhancements, including nu-

merous bug fixes. 
• First time completion of the guide, which now also explains team col-

laboration for authors and REs. 
• For TSUs this version now offers a feature to generate a spreadsheet 

for publication of comments with the Author Responses. The latter is 
of particular relevance for Review Comments that have received mul-
tiple Author Responses to the same comment, as this is typically the 
case for entire report comments. The author history fully supports the 
reviewing and editing of such Author Responses. The spreadsheet 
REtool can export at the end of such editing is in a format that fits the 
needs of the IPCC secretariat for the final publication of the Review 
Comments together with the Author Responses.

• 1.8fc11! Extending the support for latest Author Responses for SR1.5. A few bug fixes 
(export core data error handling; export to PDF).

•
• 1.8fc10! Added as a new feature menu command ‘Helpers -> Enter page and line 

numbers for comparison draft...’ that allows manual entry of page and line 
numbers for a matching passage in the comparison draft. The matching 
passage as listed in the TOC meta data is now shown in comparison sec-
tion field. Extending the support for latest Author Responses for SR1.5. 
Several bug fixes (imports of Review Comments for SRCCL, Author Re-
sponses SR1.5 and SRCCL) and polishing.

•
• 1.8fc9! Added new feature to produce a comments spreadsheet for a RE colleague 

who prefers not to work with REtool but wants to use just that spreadsheet. 
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The generated spreadsheet once filled out with RE Annotations can then be 
reimported into REtool and merged with RE work as done within REtool. 
The File menu was restructured accordingly and should be better to under-
stand intuitively. Many bug fixes and improvements in terms of compatibility 
with latest TAT. REtool-textlinks was modified too.

• 1.8fc8   First release of REtool for Windows systems that requires not a FileMaker li-
cense.  Added full support for CCPs and CCBs and improved the working 
with SPMs.

•
• 1.8fc7   !Various bug fixes and improvements on usability by introducing the REtool 

work folders and TAT-textlinks folder.
•
• 1.8fc6   !First public release of REtool via the new REtool home page.
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